poj1562 Oil Deposits BFS

Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12620 Accepted: 6887

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source

#include<stdio.h>
#include<stdlib.h>
int fx[8][2]= {{0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};//八个方向
char map[101][101];//储存地图
int m,n;
void sou(int x,int y)
{
    int i,tx,ty;
    for(i=0; i<8; i++)//八个方向搜索
    {
        tx=x+fx[i][0];//搜索
        ty=y+fx[i][1];
        if(tx<0||tx>=m||ty<0||ty>=n)//越界
           continue;
        if(map[tx][ty]=='*')//陆地
            continue;
        if(map[tx][ty]=='@')//油田
        {
            map[tx][ty]='*';//油田变陆地,防止回溯循环
        }
        sou(tx,ty);
    }
}
int main()
{
    int i,j,count;
    while(scanf("%d%d",&m,&n),m!=0||n!=0)
    {
        for(i=0; i<m; i++)
            scanf("%s",map[i]);
        count=0;
        for(i=0; i<m; i++)
            for(j=0; j<n; j++)
            {
                if(map[i][j]=='@')
                {
                    sou(i,j);//无路可搜,油田+1
                    count++;
                }
            }
        printf("%d\n",count);
    }
    return 0;
}
<strong><span style="font-size: 18px; color: rgb(255, 0, 0);">搜索到油田将之变为陆地(防止回溯无限搜索),然后继续向八个方向搜索油田,进而变为陆地,直到搜不到油田为止,油田数目加一;然后进行下一次搜索。</span></strong>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值