POJ - 3660 - Cow Contest


题目连接:http://poj.org/problem?id=3660

题目描述

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

有n(1<=n<=100)个学生参加编程比赛。

给出m条实力信息。(1<=M<=4500)

其中每一条的格式为 A B (1<=A<=N,1<=B<=N,A!=B) 意思是A的实力比B强。

如果A比B强且B比C强,那么A一定比C强。

问最后有多少名学生可以确定他的排名。

保证输入信息不存在矛盾

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

第一行n和m。

以下m行 A B 表示A实力比B强。

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

输出答案

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

解题思路

对每给的一个胜负关系连一条边,最后跑一次Floyd,然后判断一头牛所确定的关系是否是n-1次,若是,则这头牛的排名可以确定
简单说就是这头牛可以和另一只不管怎样如果能连接到,就说明时是可以确定的

AC代码

#include<iostream>
#include<cstring>
using namespace std;
int dis[110][110];
int main () {
    int n, m;
    int a, b;
    while(~scanf("%d %d", &n, &m)) {
        memset(dis, 0, sizeof(dis));
        for(int i = 1; i <= m; i++) {
            cin >> a >> b;
            dis[a][b] = 1;
        }
        for(int k = 1; k <= n; k++) {
            for(int i = 1; i <= n; i++) {
                for(int j = 1; j <= n; j++) {
                    dis[i][j] = dis[i][j] || (dis[i][k] && dis[k][j]);
                } 
            }
        }
        int ans = 0;
        for(int i = 1; i <= n; i++) {
            int sum = 0;
            for(int j =1; j <= n; j++) {
                if(dis[i][j] || dis[j][i])
                    sum++;
            }
            if(sum == n-1) 
                ans++;
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值