Cow Contest POJ - 3660(Floyd,传递闭包)

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2
/*题意:第一行两个n,m表示牛的个数和牛之间的胜负关系,<A,B>表示为A打过B,问能确定多少牛和其他所有牛的关系?传递闭包。对于一个节点k,如果i能到k,j能到k,那么j就能到i。求传递闭包,就是把图中所有满足这样传递性的节点都弄出来,这样我们就能知道任意两个节点之间是否相连。题目大概就是说,有n头牛,给出牛之间的强弱关系,能确定具体排名的牛的数量是多少
思路就是用那个传递闭包,找推出所有关系,用三个for循环,第一个for循环是遍历所有的点,第二个,第三个都是遍历其他点来看传递性找关系。
想要确定一个牛的排名,那么只要看他的关系是不是有n-1个。
*/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int map[110][110],n,m;
int main()
{
int i,j,k;
   while(~scanf("%d %d",&n,&m))
   {
       memset(map,0,sizeof(map));
       while(m--)
       {
           int a,b;
           scanf("%d %d",&a,&b);
           map[a][b] = 1;
       }
       for(k=1;k<=n;k++)
       {
          for(i=1;i<=n;i++)
          {
              for(j=1;j<=n;j++)
              {
                 if(map[k][j]==1&&map[i][k]==1)
                 map[i][j] = 1;
              }

          }
       }
       int sum=0;
       for(i=1;i<=n;i++)
       {
          int t = 0;
          for(j=1;j<=n;j++)
          {
              t += map[i][j]+map[j][i];
          }
          if(n-t == 1)//是不是该牛与其他每个牛都能确定关系
          sum++;
       }
       printf("%d\n",sum);
   }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值