Big Number

Big Number

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19

思路:
1.按照阶乘的定义算这个数的阶乘(而且用到大整数计算),然后再检查位数。一看题目条件肯定会超时。
2.求一个数有N多少位,可用log10(N)+1,于是,求N!有多少位
log10(1*2*3*……*n)=log10(1)+log10(2)+……+log10(N)+1

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner input = new Scanner (System.in);
		int n = input.nextInt();
		for (int i = 0;i < n;i++) {
			int m = input.nextInt();
			double sum = 0;
			for (int j = 1;j <= m;j++) {
				sum = sum + Math.log10(j);
			}
			System.out.println((int)sum+1);
		}
	}
}

3.采用近似计算的方法,这个一般人是想不到的(我承认我是一般人),网上搜的,叫斯特林[striling]公式。
这个公式的意思就是:也就是说当n很大的时候,


# include <iostream>
# include <math.h>
const double PI = 3.14159265 ;
using namespace std;
int main()
{
 int N,T;
 cin>>T;
 while(T--)
 {
   cin>>N;
   int len=ceil((N*log((double)N)-N+log(2.0*(double)N*PI)/2.0)/log(10.0));
   if(!len)len++; //len=0 when n=1 notice
   cout<<len<<endl;
 }
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值