A Magic Lamp HDU - 3183 (ST表)

Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum. 
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream? 

Input

There are several test cases. 
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero. 

Output

For each case, output the minimum result you can get in one line. 
If the result contains leading zero, ignore it. 

Sample Input

178543 4 
1000001 1
100001 2
12345 2
54321 2

Sample Output

13
1
0
123
321

思路:若要在长度为N的序列中挑N-M个数,则很容易知道  第一个数一定是在[0,N-(N-M)-1]中挑选这个区间的最小值,以此类推。

#include <iostream>
#include <algorithm>
#include<cmath>
#define ll long long
using namespace std;

char a[1010],ans[1008611];//原始输入数组
int st[1010][20];//st表
int m;
int mmin(int i,int j){
    if(a[i]<=a[j]){
        return i;
    }
    else return j;
}
void init(int n)
{
    for (int i = 0; i < n; i++)
        st[i][0] = i;
    
    for (int i = 1; (1 << i) <= n; i++)
    {
        for (int j = 0; j + (1 << i) - 1 < n; j++){
            st[j][i] = mmin(st[j][i - 1],st[j + (1 << (i - 1))][i - 1]);
        }
    }
}

int Search(int l, int r)
{
    int k = (int)(log((double)(r - l + 1)) / log(2.0));
    return mmin(st[l][k],st[r - (1 << k) + 1][k]);
}

int main()
{
    while(~scanf("%s%d",a,&m)){
        int len=strlen(a);
        init(len);
        m=len-m;
        int l=0,cnt=0;
        while(m--){
            l=Search(l, len-m-1);//找到此在区间内的最小值坐标并更新左区间
            ans[cnt++]=a[l++];
        }
        int i=0;
        for(i=0;i<cnt;i++){//去除前导0
            if(ans[i]!='0')break;
        }
        if(i==cnt)printf("0\n");//特判都为0的情况
        else{
            while(i<cnt){
                printf("%c",ans[i]);
                i++;
            }
            printf("\n");
        }
    }
        return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值