训练3 习题3

题目:

Input
Input contains multiple test cases. Each test case is described in a line as follow:<br>N value_1 value_2 …value_N <br>It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.<br>A test case starting with 0 terminates the input and this test case is not to be processed.<br>
 

Output
For each case, print the maximum according to rules, and one line one case.<br>
 

Sample Input
  
  
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
  
  
4 10 3



思路:


令d[i]表示以第i个数字结尾的和最大的递增子序列  得到d[i]=max(d[i],d[j]+a[i]) (j为1到a之间的数  且a[i]>a[j])



#include<cstdio>
#include<algorithm>
using namespace std;
const int N = 1005;
int a[N], d[N];
int main()
{
    int ans,n;
    while (scanf ("%d", &n), n)
    {
        ans=0;
        for (int i = 1; i <= n; ++i)
        {
            scanf ("%d", &a[i]);
            d[i]=a[i];
            for(int j=1;j<i;++j)
                if(a[i]>a[j]) d[i]=max(d[i],d[j]+a[i]);
            ans=max(ans,d[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值