ACM刷题之HDU————How Many Trees?

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1225 Accepted Submission(s): 645
 
Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 
 
Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
 
Output
You have to print a line in the output for each entry with the answer to the previous question.
 
Sample Input
1
2
3
 
Sample Output
1
2
5
 
输入节点数。输出二叉树的可能性。
网上有公式: h(n ) = h(n-1)*(4*n-2) / (n+1)

用JAVA来做。
下面是ac代码:
import java.math.BigInteger;
import java.util.Scanner;
import java.math.*;
import java.text.*;
public class Main{

	public static void main(String[] args) {
		// TODO 自动生成的方法存根
		Scanner cin=new Scanner(System.in);
		int i=4;
		BigInteger[] big = new BigInteger[102];
		big[1] = new BigInteger("1");
		big[2] = new BigInteger("2");
		big[3] = new BigInteger("5");
		BigInteger n1 = new BigInteger("24");

		BigInteger n = new BigInteger("4");
		BigInteger cont = new BigInteger("4");
		BigInteger two = new BigInteger("2");
		BigInteger one = new BigInteger("1");
		BigInteger four = new BigInteger("4");
		
		for(i=4;i<101;i++)
		{
			big[i]=big[i-1].multiply(four.multiply(cont).subtract(two)).divide(cont.add(one));
			
			
			cont=cont.add(one);
		}
		
		while(cin.hasNext())   //等同于!=EOF
		{
			i=cin.nextInt();
			System.out.println(big[i]);
		}
	}

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值