杭电1130How Many Trees?

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3286    Accepted Submission(s): 1907


Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 
 

Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 5
 

Source
UVA
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1131  1134  1133  1267  1100 
 
卡特兰数,代码都一样:
#include<cstdio>
#include<cstring>
#define N 60
using namespace std;
int main()
{
    int h[101][2*N+1],i,j,k,l,n;
    memset(h,0,sizeof(h));
    h[0][1]=1;h[1][1]=1;
    for(i=2;i<=100;i++)
    {
        for(j=0;j<i;j++)
            for(k=1;k<N;k++)
                for(l=1;l<N;l++)
        h[i][k+l-1]+=h[j][k]*h[i-j-1][l];
        for(j=1;j<N;j++)
        {
            h[i][j+1]+=h[i][j]/10;
            h[i][j]%=10;
        }
    }
    while(scanf("%d",&n)!=EOF)
    {
        i=N;
        while(h[n][--i]==0);
        for(j=i;j>0;j--)
        printf("%d",h[n][j]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值