hdu2594(KMP)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1781    Accepted Submission(s): 649


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
  
  
clinton homer riemann marjorie
 

Sample Output
  
  
0 rie 3
 

Source
 

Recommend
lcy
 


本题要求两个字符的前一个的前缀与后一个的后缀的最长公共部分。

本题至少有两种思考方法:

     1.暴力枚举,枚举第一个串的结束位置,再依次与第二个串比较,时间复杂度为O(N^2);

     2.将后一个字符串接在前一个后面,运用KMP算法中的next【】数组做,时间复杂度为O(N);

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;


const int MAXN=50000*2+100;
char str[MAXN];
int next[MAXN];
void getnext()
{
	int j=1,k=0,len;
	next[0]=-1;
	next[1]=0;
	len=strlen(str);
	while(j<len)
	{
		if(str[j]==str[k])
		{
			next[j+1]=k+1;
			j++;
			k++;
		}
		else if(k==0)
		{
			next[j+1]=0;
			j++;
		}
		else
			k=next[k];
	}
}

int main()
{
	int len1,len2,i;
	int Min;
	while(~scanf("%s",str))
	{
		len1=strlen(str);
		scanf("%s",str+len1);
		memset(next,0,sizeof(next));
		getnext();
		len2=strlen(str);

		Min=len1;
		if(Min>len2-len1)
			Min=len2-len1;
		if(Min<next[len2])
			next[len2]=Min;
		for(i=0;i<next[len2];i++)
		{
			printf("%c",str[i]);
			if(i==next[len2]-1)
				printf(" ");
		}
		printf("%d\n",next[len2]);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值