poj2406(KMP)

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 27614 Accepted: 11566

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

 
本题要求给定字符串的最小重复子串的重复次数。即求给定的字符串的最小重复单元即可。
可用KMP算法求得next[len],若len%(len-next[len])==0,则最小重复单元的长度为next[len],n=len/(len-next[len]);否则给定的字符串不能由某个字串重复得到。
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN=1000000+100;
int next[MAXN];
char str[MAXN];


void getNext(char *p)
{
    int j,k;
    j=0;
    k=-1;
    int len=strlen(p);
    next[0]=-1;
    while(j<len)
    {
        if(k==-1||p[j]==p[k])
        {
            j++;
            k++;
            next[j]=k;
        }
        else k=next[k];
    }
}

void solve(int len)
{
	if(len%(len-next[len])!=0)
		printf("1\n");
	else 
		printf("%d\n",len/(len-next[len]));
}

int main()
{
//	freopen("in.txt","r",stdin);
	while(~scanf("%s",str))
	{
		if(strcmp(str,".")==0)
			break;
		getNext(str);
		solve(strlen(str));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值