RCP使用JCL部署到WebStart上要注意的问题

Eclipse plugin 专栏收录该内容
3 篇文章 0 订阅
把RCP程序部署到WebStart上时,如果有使用到JCL的,会出现一个严重的问题.程序会跑不起来,报错如下
Caused by org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy. 
You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.
,这个问题的原因是JCL的classloader与eclipse的classloader冲突造成的,具体可以看 http://www.qos.ch/logging/classloader.jsp
解决办法是使用slf4j.jar来替换JCL.slf4j在 http://www.slf4j.org/
下载.
  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页

打赏作者

xiaofenguser

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值