HDU 1028 Ignatius and the Princess III(传说中的母函数求方案数)

很有成就感的说。。现在再看简直觉得难以想象,当时居然能用bfs做。。。虽然TLE了。。

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9048    Accepted Submission(s): 6366


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 

Author
Ignatius.L

Statistic |  Submit |  Discuss  |   Note
呵呵,用BFS和set,multiset,直接爆表了。。思路和那个第一次见很难理解的蛇出洞题很像,但这里用的是multiset,来保存访问信息。爆表爆表。。

#include <iostream>
#include <queue>
#include <set>
using   namespace   std;
#define   MAXN 120
int   n,CNT;              //输 n和 CNT
set<multiset<   char > > S[MAXN+1];   //存 访
struct   node
{
                   int   x;                                                          //当
                multiset<   char > s;  //节
}init,now,nextt;                                                     
queue<node> Q;
int   BFS()
{
                   for ( int   j=0;j<MAXN+1;++j) S[j].clear();
                CNT = 0;
                   for ( int   k=1;k<=n;++k)                             //先放n个初始节点进去
                {
                                node nod;
                                nod.x = k;
                                nod.s.insert(k);
                                Q.push(nod);
                                S[k].insert(nod.s);
                }
                init.x = 0;init.s.clear();
                Q.push(init);
                   while (!Q.empty())
                {
                                now = Q.front();Q.pop();
                                   if (now.x==n) {CNT++; continue   ;}
                                   for ( int   i=1;i<=n;++i)
                                {
                                                nextt.x = now.x+i;
                                                nextt.s = now.s;
                                                nextt.s.insert(i);    
                                                   if (nextt.x<=n&&S[nextt.x].count(nextt.s)==0)                 
                                                {              
                                                                Q.push(nextt);                                                      
                                                                S[nextt.x].insert(nextt.s);     
                                                }
                                }
                }
                   return   CNT;
}
int   main()
{
                   while (cin>>n)
                                cout<<BFS()<<endl;
                   return   0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值