Game of Flying Circus --(hdu5515)

The discovery of anti-gravitations technology changed the world. The invention of anti-gravitation shoes (Grav-shoes) enables people to fly in the sky freely. This led to the rise of a new sky sport:  ``Flying Circus"

Utilizing Grav-shoes and personal flying suits, competitors battle it out in a special field, where they compete scoring obtain  m m points within a certain time limit. The field is a square with edge length  300 300 meters. Moreover, there are four buoys floating at each corner of the square. Four buoys are numbered as  1,2,3,4 1,2,3,4 in clockwise order. 



Two players start at buoy  #1 #1. When game begin, they will try to touch four floating buoys in clockwise order. 
(Since buoy  #1 #1 is the start point, the first buoy they need to touch will be buoy  #2 #2, and after that, they need to touch buoy  #3,#4,#1 #3,#4,#1 in order)  Note that they could fly freely in the field, even fly inside the square field. 

Under two situations the player could score one point. 

1.  If you touch a buoy before your opponent, you will get one point. For example if your opponent touch the buoy  #2 #2 before you after start, he will score one point. So when you touch the buoy  #2 #2, you won't get any point. Meanwhile, you cannot touch buoy  #3 #3 or any other buoys before touching the buoy  #2 #2

2.  Ignoring the buoys and relying on dogfighting to get point. If you and your opponent meet in the same position, you can try to fight with your opponent to score one point. For the proposal of game balance, two players are not allowed to fight before buoy  #2 #2 is touched by anybody. 

There are three types of players. 

Speeder: As a player specializing in high speed movement, he/she tries to avoid dogfighting while attempting to gain points by touching buoys. 
Fighter: As a player specializing in dogfighting, he/she always tries to fight with the opponent to score points. Since a fighter is slower than a speeder, it's difficult for him/her to score points by touching buoys when the opponent is a speeder. 
All-Rounder: A balanced player between Fighter and Speeder. 

There will be a training match between Asuka (All-Rounder) and Shion (Speeder). 
Since the match is only a training match, the rules are simplified:  the game will end after the buoy  #1 #1  is touched by anybody. Shion is a speed lover, and his strategy is very simple: touch buoy  #2,#3,#4,#1 #2,#3,#4,#1 along the shortest path. 

Asuka is good at dogfighting, so she will always score one point by dogfighting with Shion, and  the opponent will be stunned for T seconds after dogfighting.Since Asuka is slower than Shion, she decides to fight with Shion for only one time during the match. It is also assumed that if Asuka and Shion touch the buoy in the same time, the point will be given to Asuka and Asuka could also fight with Shion at the buoy. We assume that in such scenario, the dogfighting must happen after the buoy is touched by Asuka or Shion. 

The speed of Asuka is  V1 m/s V1 m/s. The speed of Shion is  V2 m/s V2 m/s. Is there any possibility for Asuka to win the match (to have higher score)?
Input
The first line contains an integer  t (0<t1000) t (0<t≤1000), followed by  t t lines. 
Each line contains three double  T, V1 T, V1 and  V2 (0V1V22000,0T2000) V2 (0≤V1≤V2≤2000,0≤T≤2000) with no more than two decimal places, stands for one case.
Output
If there exist any strategy for Asuka to win the match, output ``Yes", otherwise, output ``No".
Sample Input
2
1 10 13
100 10 13
Sample Output
Case #1: No
Case #2: Yes

        
  
Hint
Asuka could fly to the mid point of the edge between buoy #2 and buoy #3, and wait there until Shion come.  Asuka will fight with Shion when they meet. As a result, Shion will be stunned (It means Shion cannot move for 100 seconds.) Then Asuka could fly back to buoy #2, since the buoy #2 is touched, she will get no point by touching buoy #2. But after that, she could fly to buoy #3, #4, #1 along the edge and get three points.
 
 
 
 
题意及题解:http://blog.csdn.net/snowy_smile/article/details/49535301
简直是再清晰不过了:
#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;


int main()
{
    int T;
    scanf("%d",&T);
    int cas=0;
    while(T--)
    {
        double t,v1,v2,t1,t2;
        cas++;
        scanf("%lf%lf%lf",&t,&v1,&v2);
        t1=300.0/v1;
        t2=300.0/v2;
        if(v1==v2)
        printf("Case #%d: Yes\n",cas);
        else if(v1*v1*2>v2*v2)//能否 #2——#3相遇
        {
            double l=0,r=300;
            for(int i=0;i<=100;i++)//二分查找相遇点
            {
                double mid=(l+r)/2;
                double a=sqrt((300*300+mid*mid))/v1;
                double b=(300+mid)/v2;
                if(a>b)
                {
                    l=mid;
                }
                else
                r=mid;
            }
           double ta=sqrt(l*l+300*300)/v1+l/v1+2*t1;
        double tb=t+3*t2;
        //  计算谁能先到达#4点
            if(ta>tb)
            printf("Case #%d: No\n",cas);
            else
            printf("Case #%d: Yes\n",cas);
        }
        else if(3*v1>v2)//能否再#3——#4相遇
        {
            double l=0.0,r=300.0,mid;
            for(int i=0;i<100;i++)//二分查找相遇点
            {
                mid=(l+r)/2;
                double a=sqrt(300*300+(300-mid)*(300-mid));
                a=a/v1;
                double b=(600+mid)/v2;
                if(a>b)
                l=mid;
                else
                r=mid;
            }
            double a,b;
            a=sqrt(300*300+(300-l)*(300-l))/v1+sqrt(300*300+l*l)/v1+3*t1;
            b=t+4*t2;
            //  计算谁能先到达#1点
            if(a>b)
            printf("Case #%d: No\n",cas);
            else
            printf("Case #%d: Yes\n",cas);
        }
        else
        printf("Case #%d: No\n",cas);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值