XYZZY

15 篇文章 0 订阅

Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable.
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms.

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player’s energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time.

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing:

the energy value for room i
the number of doorways leaving room i
a list of the rooms that are reachable by the doorways leaving room i
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

Output
In one line for each case, output “winnable” if it is possible for the player to win, otherwise output “hopeless”.

Sample Input
5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1

Sample Output
hopeless
hopeless
winnable
winnable
题意:出发点就有100点能量,到达一个新点能得到一个正或者负的能量,可走重复的点 ,所以如果有环,且环能得到总能量大于0,则必定可以到最终点
思路:重点是判断是否有正环的出现,之后再判断环上的点与终点是否连通就可以了。判断出现正环的条件为某个点入队列次数>=n。

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
#define inf 0x7f7f7f7f
int map[1005][1005],dis[1005],count[1005],n;
bool reach[1005][1005];//判断两点是否可以到达
void floyd()
{
    for(int k=1;k<=n;k++)
     for(int i=1;i<=n;i++)
      for(int j=1;j<=n;j++)
        reach[i][j]=(reach[i][j]||(reach[i][k]&&reach[k][j]));       
}
bool spfa(int st)
{
    queue<int>q;
    memset(dis,0,sizeof(dis));
    memset(count,0,sizeof(count));
    dis[1]=100;
    q.push(st);
    while(!q.empty())
    {
        int temp=q.front();
        q.pop();
        count[temp]++;
        if(count[temp]>=n) return reach[temp][n];//如果某个点的次数超过n次,那么说明存在正环,此时只要判断这点到n点是否可达就行了
        for(int i=1;i<=n;i++)
        {
            if(map[temp][i]!=inf&&dis[temp]+map[temp][i]>dis[i]&&dis[temp]+map[temp][i]>0)//由于出现正环,所以要求最长路
            {
                q.push(i);
                dis[i]=dis[temp]+map[temp][i];
            }
        }
    }
    return dis[n]>0;
}
int main()
{
    while(cin>>n)
    {
        if(n==-1) break;
        for(int i=0;i<=n;i++)
        for(int j=0;j<=n;j++)
        map[i][j]=inf;
        memset(reach,false,sizeof(reach));
        for(int i=1;i<=n;i++)
        {
            int num,k;
            cin>>k>>num;
            for(int j=1;j<=num;j++)
            {
                int t;cin>>t;
                map[i][t]=k;
                reach[i][t]=true;
            }
        }
        floyd();
        if(!reach[1][n]) cout<<"hopeless"<<endl;
        else 
        {
            if(spfa(1)) cout<<"winnable"<<endl;
            else cout<<"hopeless"<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值