Problem I

                                     Problem  I

Time Limit: 2000/1000 MS (Java/Others)     Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 512    Accepted Submission(s): 298
Problem Description
Long long ago, a problem was spread all over the world , but no one could solve it . Now, due to the Internet , it has been solved perfectly(See figure 1).

Now here’s a problem much harmonious.
ErEr has big cake weighing m grams , at the same time he has n children . and every children want a part of the cake weighs even number(偶数) of grams. The children are extremely hungry and want to start their meal as soon as possible, that's why you should help them and find out, if they can divide the cake in the way they want. For sure, each of them should get a part of positive weight.
 
Input
The first line of input gives the number of cases, T (at most 100).
each case has there numbers m,n. (1<=m<=10000,1<=n<=100)
 
Output
Print YES, if the boys can divide the cake into n parts, each of them weighing even number of kilos; and NO in the opposite case.
 
SampleInput
2
10 2
11 2
 
SampleOutput
YES
NO

 

 

 

 

 

 

题意:分蛋糕 能被二整除就行~

代码:

 

#include<iostream>   
using namespace std;  
int main()  
{  
    int n; 
	int m; 
	int cas;
	cin>>cas;
	while(cas--)
	{
		
	
    cin>>n>>m;
  
 
     if(n==2||n==0)  
     cout<<"NO"<<endl;  
      
    if(n%2==0)  
     cout<<"YES"<<endl;  
     else   
     cout<<"NO"<<endl; 
	}
    return 0;  
}  		


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值