1009 最短路

                                                          Choose the best route
                     Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
                             Total Submission(s) : 14 Accepted Submission(s) : 7
Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1

Sample Output
  
  
1 -1

Author
dandelion

Source
2009浙江大学计算机研考复试(机试部分)——全真模拟
 
题意:
一道简单的dij题 但是亮点是中间加入了超级源(就是这一点到输入点的距离长为0)
代码:
#include<stdio.h>
#include<iostream>
int a[1005][1005],n;
int Dijkstra(int v,int o)
{
    int s[1005],d[1005],i,j,m,min;
    for (i=0;i<=n;i++)
    {
        s[i]=0;
        d[i]=a[v][i];
    }
    s[0]=1;
    d[0]=0;
    for (i=0;i<=n;i++)
    {
        min=100000000;
        for (j=0;j<=n;j++)
        {
            if (s[j]==0&&d[j]<min)
            {
                min=d[j];
                m=j;
            }
        }
        if (min==100000000)break;
        s[m]=1;
        for (j=0;j<=n;j++)
        {
            if (d[j]>d[m]+a[m][j]&&s[j]==0)
                d[j]=d[m]+a[m][j];
        }
    }
    return d[o];
}
int main()
{
    int m,o,p,q,t,w,c,i,j;
    while (scanf("%d%d%d",&n,&m,&o)!=EOF)
    {
        for (i=0;i<1005;i++)
            for (j=0;j<1005;j++)
                a[i][j]=100000000;
        while (m--)
        {
            scanf("%d%d%d",&p,&q,&t);
            if (a[p][q]>t)
                a[p][q]=t;
        }
        scanf("%d",&w);
        while (w--)  //超级源 0点到任意到输入点的路程长为0
        {
            scanf("%d",&c);
            a[0][c]=0;
        }
        if (Dijkstra(0,o)>=100000000)
            printf("-1\n");
        else
            printf("%d\n",Dijkstra(0,o));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值