2013寒假SD高校ACM周赛3(SDUT)

      A题                                                                                                                                   Steps

Time Limit: 3000MS Memory limit: 65536K

题目描述

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

输入

Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers: 0<= x <= y < 231

输出

For each test case, print a line giving the minimum number of steps to get from xto y.

示例输入

3
45 48
45 49
45 50

示例输出

3
3
4

 

题意:从起点坐标x到终点坐标y一共需要多少步 起点和终点的前一步必须为1 且前一步和必须必后一步大一或者小一或者等于一

代码:

#include<iostream>

using namespace std;
int main()
{
	int s,e;
	int n;
	cin>>n;
	while(n--)
	{
	    cin>>s>>e;
	    int len=e-s;
	    if(len==0)
	    cout<<0<<endl;
	    else if(len==1)
	    cout<<1<<endl;
	    else if(len==2)
	    cout<<2<<endl;
	    else 
	    {
    		len-=2;
    		int bushu=3;
    		for(int i=2;;i++)
    		{
		    	len-=i;
		    	if(len<=0)
		    	break;
		    	bushu++;
		    	len-=i;
		    	if(len<=0)
		    	break;
		    	bushu++;
		    	
		    	
		    }
		    cout<<bushu<<endl;
    		
    	}
	    
	
	}
	return 0;
}


 

b题

                                                                                                                The ? 1 ? 2 ? ... ? n = k problem

Time Limit: 3000MS Memory limit: 65536K

题目描述

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

输入

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

输出

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

示例输入

2

12

-3646397

示例输出

7

2701

 

 

题目:前几个数从1到n 前面可以使加号也可以是减号~ 求相加之和等于目标值得时候n的最小值
思路:条件一:从1到n相加之和必须大于目标值k
条件二:若有一个值x满足1+2+3+4+5+…x+n=k2
且k2-k=2x 即相减之后 为偶数
 
 
代码:
#include<iostream>
using namespace std;
int main()
{
	int k;
	int cas;	
	int temp;
	int n;
	int temp2;
	int i;
	cin>>cas;
	while(cas--)
	{
		cin>>k;
		k=abs(k);
		for(i=0;;i++)
		{
			temp=i*(i+1)/2;			 
			if(temp>k) break;			
		}
		n=i;
		for(i=0;;i++)
		{
	       temp2=n*(n+1)/2-k;
	       
	       
	       if(temp2%2==0) break;
	       n++;
		}
		cout<<n<<endl;
		if(cas) cout<<endl;
		
	}
	return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值
>