hdu _ 1.3.7_排列2

                                       排列2

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2031 Accepted Submission(s): 653
 
Problem Description
Ray又对数字的列产生了兴趣:
现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。
Input
每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。
Output
对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
每组输出数据间空一行,最后一组数据后面没有空行。
Sample Input
1 2 3 4
1 1 2 3
0 1 2 3
0 0 0 0
Sample Output
1234 1243 1324 1342 1423 1432
2134 2143 2314 2341 2413 2431
3124 3142 3214 3241 3412 3421
4123 4132 4213 4231 4312 4321

1123 1132 1213 1231 1312 1321
2113 2131 2311
3112 3121 3211

1023 1032 1203 1230 1302 1320
2013 2031 2103 2130 2301 2310
3012 3021 3102 3120 3201 3210

pe代码:

#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<stdio.h>
#include<algorithm>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;//头文件
int main()
{
	string str;
	char a[5];
	string key;	
	while(cin>>a[1]>>a[2]>>a[3]>>a[4])
	{
		if(a[1]=='0'&&a[2]=='0'&&a[3]=='0'&&a[4]=='0')
		break;
		int flag1=0;
		int i=0;
		int flag=0;
		for(int i=1;i<=4;i++)
		{
			str=str+a[i];
		}
		sort(str.begin(),str.end());
	
		while(1)
		{
		if(str[i]=='0')
		i++;
		else
		 break;		
		}
		key=str[i];//找出第一个不是零的数 用于格式化输出 
	
		   if(str[0]=='0')
			flag=1;
			else if(str[0]=='0'&&str[1]=='0')
			flag=1;
			else if(str[0]=='0'&&str[1]=='0'&&str[2]=='0')
	    	flag=1;
		if(flag!=1)
		cout<<str<<" ";//将第一个输入来 
		while(next_permutation(str.begin(), str.end()))
		{
			if(str[0]=='0')
			continue;
			else if(str[0]=='0'&&str[1]=='0')
			continue;
			else if(str[0]=='0'&&str[1]=='0'&&str[2]=='0')
			continue;
			else
			{
			   if(str[0]==key[0])
			   cout<<str;
			   else  //格式化输出 
			   {
			   	cout<<endl;
			   	cout<<str;
			   	if(key[0]!=str[0])
			   	cout<<" ";   			
   				key[0]=str[0];
   			    flag1=1;
   			   }
			   if(flag1==0)
			   cout<<" ";			    
			   flag1=0;			
			}		
		}
	     cout<<endl;	
		str="";		
	}
	return 0;	
}
 

//PE原因 最后一个空格没有处理 我去去~
 

代码2:

#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
    int a[4],i;
    int cas=0;
    while (scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3])!=EOF)
    {

        if (a[0]==0&&a[1]==0&&a[2]==0&&a[3]==0)break;
        if (cas!=0)
            cout<<endl;
        cas++;
        sort(a,a+4);
        int count=0;
        for (i=0;i<4;i++)
        {
            if (a[i]==0)
                count++;
        }
        if (count==1)
        {
            swap(a[0],a[1]);
        }
        if (count==2)
        {
            swap(a[0],a[2]);
        }
        if (count==3)
        {
            swap(a[0],a[3]);
        }
        for (i=0;i<4;i++)
            cout<<a[i];
        int t=a[0];
        while (next_permutation(a,a+4)) 
        {
            int flag=0;
            if (t<a[0])
            {
                t=a[0];
                cout<<endl;
                flag++;
            }
            if (flag==0)
                cout<<" ";
            for (i=0;i<4;i++)
                cout<<a[i];

        }

        cout<<endl;
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值