hdu 1841

                    Find the Shortest Common Superstring

   Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
   Total Submission(s): 1120 Accepted Submission(s): 286


Problem Description
The shortest common superstring of 2 strings S 1 and S 2 is a string S with the minimum number of characters which contains both S 1 and S 2 as a sequence of consecutive characters. For instance, the shortest common superstring of “alba” and “bacau” is “albacau”.
Given two strings composed of lowercase English characters, find the length of their shortest common superstring.

Input
The first line of input contains an integer number T, representing the number of test cases to follow. Each test case consists of 2 lines. The first of these lines contains the string S 1 and the second line contains the string S 2. Both of these strings contain at least 1 and at most 1.000.000 characters.

Output
For each of the T test cases, in the order given in the input, print one line containing the length of the shortest common superstring.

Sample Input
  
  
2 alba bacau resita mures

Sample Output
  
  
7 8

Author
Mugurel Ionut Andreica

Source

Recommend
lcy
这题和hdu 1867 差不多

code:
#include<iostream>
#include<cstring>
using namespace std;
char S[1000005],T[1000005];
int next[1000005];
void get_next(char *t)
{
	int i=0,j=-1;
	next[0]=-1;
	int Lt=strlen(t);
	while(i<Lt)
	{
		if(j==-1||t[i]==t[j])
		{
			++i,++j;
			next[i]=j;			
		}
		else
		j=next[j];
	}
}
int kmp(char *s,char *t)
{
	int lens=strlen(s);
	int lent=strlen(t);
	int i=0,j=0;
	get_next(t);
	while(i<lens&&j<lent)
	{
		if(j==-1||s[i]==t[j])
		{
			++i,++j;			
		}
		else
		j=next[j];
	}
	
	if(j<=lent)//有可能完全匹配 所以要加等号
		return j;
	
	return -1;
}
int main()
{
	int cas;
	scanf("%d",&cas);
	while(cas--)
	{
		scanf("%s%s",S,T);
	  int lena=kmp(S,T);
	  int lenb=kmp(T,S);
      int lT=strlen(T);
      int lS=strlen(S);
	 if(lena>lenb)
     {
		cout<<lT+lS-lena<<endl;

	}
	else
	{
		cout<<lT+lS-lenb<<endl;
	}
	}
	return 0;	
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值