hdu 4310 Hero

                                    Hero

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2030 Accepted Submission(s): 928


Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output
Output one line for each test, indicates the minimum HP loss.

Sample Input
  
  
1 10 2 2 100 1 1 100

Sample Output
  
  
20 201

Author
TJU

Source

Recommend
zhuyuanchen520

最近贱贱的刷刷水题~

code:
#include<iostream>
#include<cstring>
using namespace std;
struct Node
{
   double H,DPS;
}node[105];
int cmp(Node x,Node y)
{
	return x.DPS/x.H>y.DPS/y.H;
}
int main()
{
	int n;
	double sum;
	double gongji;
	while(cin>>n)
	{
		if(n==0) break;
		sum=0;
		gongji=0;
		memset(node,0,sizeof(node));
		for(int i=0;i<n;i++)
		{
			cin>>node[i].H>>node[i].DPS;
			gongji+=node[i].DPS;
			//cout<<gongji<<endl;			
		}
		sort(node,node+n,cmp);
		
		
		for(int i=0;i<n;i++)
	    {
    		sum+=node[i].H*gongji;
    		gongji-=node[i].DPS;
    	}
    	cout<<sum<<endl;
		
	}
	return 0;
}



Statistic | Submit | Discuss | Note
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
我已经准备好了两个分区 登陆器什么都配置好了 主区:C:\MirServer 从区:C:\MirServerB 现在开始来启动两个分区并自动合并分区 在13:03启动主区 13:05启动从区 然后我们测试游戏,再到13:12合并两个区 最后我们在13:15启动主区,也就是合并过的区 看好了 这里不清理了,我这里合区就是把主区和从区合并后 然后数据又更新到主区,这样就 不用再手动更新数据了,所以不先清理数据,我们最后测试游戏也就是合过的区。 现在主区已经启动了,我们进游戏 不好意思。。。这里主区我没选择清理数据。。我从换个ID 现在从区也启动了,我们进游戏测试 我们进游戏 到12分就自动断了..。然后合并 现在看 已经自动都关了 日志 [2012-6-29 13:12:41] 主区:C:\MirServer 从区:C:\MirServerB合并完成 我们等到15分 主区启动 然后再进游戏看 为了真实 我就不暂停 你们看时快进吧 这里已经在启动了 我们去准备上游戏.. 好了 教程就到这儿 程序现在我自测了几次 都很稳定 日志也很详细 准备再加上邮件功能,如果出错 自动发邮件 到用的时候可以把邮箱和手机绑定 然后就自动 发短信可以看到。。 谢谢大家观看 再见! ....最后个没复制上 算了 就一个开区 这里直复制到了第二个 也就是开从区的日志 Hero引擎-自动开区合区工具教程下载 http://dl.dbank.com/c0nz1hw6aq

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值