poj 2236 并查集入门

题目:

Wireless Network
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 25493 Accepted: 10592

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS


两种操作:修复点,判两点是否相连

修复:
每修复一个点,遍历所有已经修复的点,若距离符合要求,连在一起;

查询:

找到两点的根节点,看是否相同


使用并查集可以高效实现合并和find()


代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<ctype.h>	//tower()
#include<set>  
#include<map>  
#include<iomanip>	// cout<<setprecision(1)<<fixed<<a;
#include<vector>
#include<time.h>
#include<cmath>
#include<algorithm>
#include<bitset>
#include<limits.h>
#include<stack>
#include<queue>
using namespace std;
const int maxn=1010;
const int inf=0x7fffffff;

int par[maxn],depth[maxn];
int x[maxn],y[maxn],flag[maxn];

int find(int x){//非递归路径压缩
    int s,k,j;
    s=k=x;
    while(s!=par[s]) s=par[s];
    while(k!=s){
        j=par[k];
        par[k]=s;
        k=j;
    }
    return s;
}

void Union(int x,int y){
    x=find(x);
    y=find(y);
    if(x==y) return;
    if(depth[x]<depth[y]) par[x]=y;
    else{//秩小的接在秩大的下面 
        par[y]=x;
        if(depth[x]==depth[y]) depth[x]++;
    }
}

int main(){// 136K	1063MS
    int n,d,a,b,c;
    char s[3];
    while(scanf("%d%d",&n,&d)==2){
	    for(int i=1;i<=n;i++) scanf("%d%d",&x[i],&y[i]);
	    for(int i=1;i<=n;i++){
	    	par[i]=i;
			depth[i]=0;
			flag[i]=0;
	    }
	    while(~scanf("%s",s)){
	        if(s[0]=='O'){
	            scanf("%d",&a);
	            flag[a]=1;
	            for(int i=1;i<=n;i++){
	                if(flag[i] && i!=a){
	                    if((x[i]-x[a])*(x[i]-x[a])+(y[i]-y[a])*(y[i]-y[a])<=d*d){
	                        Union(i,a);
	                    }
	                }
	            }
	        }else{
	            scanf("%d%d",&a,&b);
	            if(find(a) != find(b)) printf("FAIL\n");
	            else printf("SUCCESS\n");
	        }
	    }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值