poj 2914 全局最小割入门+Stoer_Wagner模板

题目:

Minimum Cut
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 9496 Accepted: 3981
Case Time Limit: 5000MS

Description

Given an undirected graph, in which two vertices can be connected by multiple edges, what is the size of the minimum cut of the graph? i.e. how many edges must be removed at least to disconnect the graph into two subgraphs?

Input

Input contains multiple test cases. Each test case starts with two integers N and M (2 ≤ N ≤ 500, 0 ≤ M ≤ N × (N − 1) ⁄ 2) in one line, where N is the number of vertices. Following are M lines, each line contains M integers AB and C (0 ≤ AB < NA ≠ BC > 0), meaning that there C edges connecting vertices A and B.

Output

There is only one line for each test case, which contains the size of the minimum cut of the graph. If the graph is disconnected, print 0.

Sample Input

3 3
0 1 1
1 2 1
2 0 1
4 3
0 1 1
1 2 1
2 3 1
8 14
0 1 1
0 2 1
0 3 1
1 2 1
1 3 1
2 3 1
4 5 1
4 6 1
4 7 1
5 6 1
5 7 1
6 7 1
4 0 1
7 3 1

Sample Output

2
1
2

全局最小割 直接上模板...

板子用的时候注意顶点下标需要从1到n


代码:

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
const int maxn=510;
const int inf=0x3f3f3f3f;

int n,m,s,v[maxn],mat[maxn][maxn],dis[maxn];
bool vis[maxn];

int Stoer_Wagner(int n){
    int i, j;
    int res = inf;
    for (i = 0; i < n; i++)
        v[i] = i+1;//初始化第i个结点就是i
    while (n > 1)
    {
        int maxp = 1,prev = 0;
        for (i = 1; i < n; i++) //初始化到已圈集合的割大小,并找出最大距离的顶点
        {
            dis[v[i]] = mat[v[0]][v[i]];
            if (dis[v[i]] > dis[v[maxp]])
                maxp = i;
        }
        memset(vis, 0, sizeof(vis));
        vis[v[0]] = true;
        for (i = 1; i < n; i++)
        {
            if (i == n - 1)  //只剩最后一个没加入集合的点,更新最小割
            {
                res = min(res,dis[v[maxp]]);
                for (j = 0; j < n; j++)  //合并最后一个点以及推出它的集合中的点
                {
                    mat[v[prev]][v[j]] += mat[v[j]][v[maxp]];
                    mat[v[j]][v[prev]] = mat[v[prev]][v[j]];
                }
                v[maxp] = v[--n];//第maxp个节点去掉,第n个节点变成第maxp个
            }
            vis[v[maxp]] = true;
            prev = maxp;
            maxp = -1;
            for (j = 1; j < n; j++)
                if (!vis[v[j]])  //将上次求的maxp加入集合,合并与它相邻的边到割集
                {
                    dis[v[j]] += mat[v[prev]][v[j]];
                    if (maxp == -1 || dis[v[maxp]] < dis[v[j]])
                        maxp = j;
                }
        }
    }
    return res;
}

int main(){//904MS	1928K
    while (scanf("%d%d",&n,&m)==2){
        memset(mat,0,sizeof (mat));
        int x,y,z;
        while(m--){
            scanf("%d%d%d",&x,&y,&z);
            mat[x+1][y+1] += z;
            mat[y+1][x+1] += z;
        }
        printf("%d\n",Stoer_Wagner(n));
    }
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值