hdu 6025 gcd+前缀和+后缀和

题目:

Coprime Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 699    Accepted Submission(s): 360


Problem Description
Do you know what is called ``Coprime Sequence''? That is a sequence consists of  n  positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
 

Input
The first line of the input contains an integer  T(1T10) , denoting the number of test cases.
In each test case, there is an integer  n(3n100000)  in the first line, denoting the number of integers in the sequence.
Then the following line consists of  n  integers  a1,a2,...,an(1ai109) , denoting the elements in the sequence.
 

Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
 

Sample Input
  
  
3 3 1 1 1 5 2 2 2 3 2 4 1 2 4 8
 

Sample Output
  
  
1 2 2
 

给一串数,删掉其中一个使得剩下的序列GCD值最大 输出最大GCD值


分析:

一开始以为要将每一个数分解为素数乘积,可是an太大了

然后往贪心方向想,结果...找不到比较靠谱的贪心方向

正解是维护一个前缀和和一个后缀和



代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+20;

int gcd(int a,int b){
    if(b==0) return a;
    else return gcd(b,a%b);
}

int t,n,a[maxn],pre[maxn],nxt[maxn];

int main(){//78ms 6400kb
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=1;i<=n;++i){
            scanf("%d",&a[i]);
        }
        pre[1]=a[1];
        for(int i=2;i<=n;++i){
            pre[i]=gcd(pre[i-1],a[i]);
        }
        nxt[n]=a[n];
        for(int i=n-1;i>=1;--i){
            nxt[i]=gcd(nxt[i+1],a[i]);
        }
        int ans=max(nxt[2],pre[n-1]);
        for(int i=2;i<n;++i){
            ans=max(ans,gcd(pre[i-1],nxt[i+1]));
        }
        printf("%d\n",ans);
    }
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值