hdu 2844 多重背包

题目:

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15046    Accepted Submission(s): 5975


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
  
  
8 4

给定n种硬币的面值和数量,以及一个m,问1-m这m个数中有多少个是能够用给定的硬币组合得到的


代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int inf=-0x3f3f3f3f;
const int maxn=100050;

int val[120],cost[120],num[120],dp[maxn];
int n,v;

inline void compak(int val,int cost){
    for(int i=cost;i<=v;++i){
        dp[i]=max(dp[i],dp[i-cost]+val);
    }
}

inline void zeroone(int val,int cost){
    for(int i=v;i>=cost;--i){
        dp[i]=max(dp[i],dp[i-cost]+val);
    }
}

inline void mulpak(int val,int cost,int num){
    if(cost*num>=v){///这种物品费用总和大于V 相当于在V的范围内可以任取多件 转化为完全背包问题
        compak(val,cost);
        return;
    }
    int k=1;
    while(k<num){
        zeroone(k*val,k*cost);
        num-=k;
        k<<=1;
    }
    zeroone(num*val,num*cost);
}

int main(){///358MS	2060K
    while(scanf("%d%d",&n,&v)==2){
        if(!n && !v) break;
        for(int i=1;i<=n;++i) scanf("%d",&cost[i]);
        for(int i=1;i<=n;++i) scanf("%d",&num[i]);
        for(int i=1;i<=v;++i) dp[i]=inf;///恰为 初始化为负数
        dp[0]=0;///容量恰为0时价值总和为零
        for(int i=1;i<=n;++i) mulpak(cost[i],cost[i],num[i]);
        int ans=0;
        for(int i=1;i<=v;++i) if(dp[i]==i) ans++;///若价值总和等于容量 则为恰好装满
        printf("%d\n",ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值