poj 2831次小生成树变形

题目:

Can We Build This One?
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 1671 Accepted: 630
Case Time Limit: 2000MS

Description

“Highways are built, then life is rich.” Now people of Big Town want to become rich, so they are planning to build highways to connect their villages.

Big Town is really big and has many villages. Its people plan to build some highways between some pairs of villages so that every pair of villages is connected by the highways either directly or indirectly. After surveying the geographical surroundings, they find that there are some paths along with highways can be built. Every path is denoted by a triplet (abc) which means a highway can built between the a-th village and the b-th village with a cost of c. In order to save money, they will select only part of the paths to build highways along so that the total cost to build highways along the selected paths is minimal under the condition that every pair of villages is connected.

It is possible that multiple such selections exist. People from every village want to have those highways of good interest to them built. But some highways can never appear in the selection since they are much too costly. So people ask whether a certain highway can be selected if they agree to cut the cost. Your task is to design a program to answer their queries.

Input

The first line of input contains three integers NM and Q (1 < N ≤ 1,000, N − 1 ≤ M ≤ 100,000, 0 < Q ≤ 100,000), where N is the number of villages, M is the number of paths, and Q is the number of queries. Each of the next M lines contains three integers ab, and c (1 ≤ ab ≤ Na ≠ b, 0 ≤ c ≤ 1,000,000). The triplet (abc) describes a path. Each of following Q lines contains two integer i and x (1 ≤ i ≤ M, 0 ≤ x) describing a query, “Can a highway be built along the i-th path if the cost of is reduced to x?” x is strictly lower than the original cost of building a highway along the i-th path. It is assumed that every pair of village will be connected either directly or indirectly if all possible highways are built. And there may be more than one highway that can be built between a pair of villages.

Output

Output one line for each query. Output either “Yes” or “No” as the answer to the the query.

Sample Input

3 4 3
1 2 10
1 3 6
2 3 4
1 3 7
4 6
1 7
1 5

Sample Output

Yes
No
Yes

给一幅图和Q个询问,每个询问为id cost,即如果将id这条边的边权改为cost的话,这条边是否可能是最小生成树中的一条边


代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1010;
const int maxm=100010;
const int inf=0x7f7f7f7f;

struct Edge{
	int u,v,c;
}E[maxm];///只参与输入输出处理
int n,m,q;
int G[maxn][maxn],path[maxn][maxn];///图 生成树中两点间最大边权
int pre[maxn],low[maxn];
bool vis[maxn],used[maxn][maxn];///点 边使用情况

int Prim(){
	int k = 1,ans = 0;///向生成树中加的点
	memset(path,0,sizeof(path));
	memset(vis,false,sizeof(vis));
	memset(used,false,sizeof(used));
	vis[k] = true;
	for(int i = 1; i <= n; i++){///点的编号从1开始
		low[i] = G[k][i];
		pre[i] = k;
	}
	for(int i = 1; i < n; i++){
		int MIN = inf;
		for(int j = 1; j <= n; j++){
			if(vis[j] == false && low[j] < MIN){
				MIN = low[j];
				k = j;
			}
		}
		ans += MIN;
		vis[k] = true;
		used[k][pre[k]] = used[pre[k]][k] = true;
		for(int j = 1; j <= n; j++){
			if(vis[j] == true && j != k)  path[j][k] = path[k][j] = max(path[j][pre[k]],low[k]);
			if(vis[j] == false && low[j] > G[k][j]){
				low[j] = G[k][j];
				pre[j] = k;
			}
		}
	}
	return ans;
}

int main(){///10872K	1750MS
	while(scanf("%d%d%d",&n,&m,&q)==3){
		memset(G,inf,sizeof(G));
		for(int i = 1; i <= m; ++i){
			scanf("%d%d%d",&E[i].u,&E[i].v,&E[i].c);
			G[E[i].u][E[i].v] = G[E[i].v][E[i].u] = min(G[E[i].u][E[i].v],E[i].c);
		}
		int ans = Prim();
		while(q--){
			int id,cost;
			scanf("%d%d",&id,&cost);
			if(path[E[id].u][E[id].v] >= cost)  printf("Yes\n");
			else  printf("No\n");
		}
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值