安迪的第一个字典(UVa 10815)

【问题描述】输入一个文本,找出所有不同的单词(连续的字母序列),按字典序从小到大输出。单词不区分大小写。

【样例输入】

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

【样例输出】

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when
#include<iostream>  
#include<string>  
#include<set>  
#include<sstream>  
using namespace std;  
  
set<string> dict;    //为字典设置一个名为dict-short的集合,它基于字符串类型;  
  
int main(){  
    string s,buf; 
    
    while (cin>>s){  
        for (int i=0;i<s.length();i++)  
          if (isalpha(s[i]))       //isalpha函数:判断字符ch是否为英文字母,若为英文字母,返回非0.若不是字母,返回0
              s[i]=tolower(s[i]);    //如果它是一个字母,把它变成小写。 
          else 
              s[i]=' ';  
        stringstream ss(s);      //如果是空格,忽略它
        while (ss>>buf) 
            dict.insert(buf);   //插入到已经是有序的集合,TYkon说这是一个平衡的树里面  (不懂)  
    }  
    for (set<string>::iterator it=dict.begin();it!=dict.end();++it)//迭代器就像一个点,从头到尾扫描它并输出  (不懂)
      cout<<*it<<endl;          //NOTICE按点输出  
    
    
    return 0;  
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值