Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
AC代码:
#include <iostream>
#include <cstdio>
using namespace std;
int N,M,sum;
char MAP[105][105];
int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
void dfs(int x,int y){
MAP[x][y] = '.';
int xx,yy;//下一步
for(int i=0; i<8; i++){
//xx = MAP[x][y] + dir[i][0];
//yy = MAP[x][y] + dir[i][1];
xx = x + dir[i][0];
yy = y + dir[i][1];
if(MAP[xx][yy] == 'W' && xx>=0 && xx<N && yy>=0 && yy<M){
MAP[xx][yy] = '.';
dfs(xx,yy);
}
}
}
int main(void)
{
cin >> N >> M;
sum = 0;
for(int i=0; i<N; i++){
for(int j=0; j<M; j++){
cin >> MAP[i][j];
}
}
for(int i=0; i<N; i++){
for(int j=0; j<M; j++){
if(MAP[i][j] == 'W'){
sum++;
dfs(i,j);
}
}
}
cout << sum << endl;
return 0;
}
类似题目:Oil Deposits HDU - 1241
链接:https://blog.csdn.net/xiaorui98/article/details/98225392