KuangBin——简单搜索——Oil Deposits HDU - 1241

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

简单来说,输入由@和*组成的地图,@表示油田,*为空

连在一起的@算一块完整的油田,其中 上下左右斜方向都算连在一起的

输出的结果就是油田的个数

以下为AC代码

DFS:

#include <iostream>

using namespace std;
const int N = 100;
char MAP[N+1][N+1];
int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
int n,m,sum;

void dfs(int x,int y){
	int xx,yy;//下一步
	for(int i=0; i<8; i++){
		xx = x + dir[i][0];
		yy = y + dir[i][1];
		if(MAP[xx][yy] == '@' && xx>=0 && yy>=0 && xx<n && yy<m){
			MAP[xx][yy] = '*';
			dfs(xx,yy);
		}
	} 
}
int main(void)
{
	while(scanf("%d %d",&n,&m) && n && m){
		sum = 0;
		for(int i=0; i<n; i++){
			for(int j=0; j<m; j++){
				cin >> MAP[i][j];
			}
		}
		//每次找到一个@后就搜索它的八个方向,并且将八个方向的@变为*
		//这样在下一次找到@时就是另一块油田了 
		for(int i=0; i<n; i++){
			for(int j=0; j<m; j++){
				if(MAP[i][j] == '@'){
					MAP[i][j] = '*';
					sum++;
					dfs(i,j);
				}
			}
		}
		
		cout << sum << endl;
	}
	return 0;
}

 

BFS:

 

#include <iostream>
#include <queue>
#include <cstring>

using namespace std;

const int N = 100;
char MAP[N+1][N+1];
bool vis[N+1][N+1]; 
int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,1},{1,-1}};
int n,m,sum;

struct Node{
	int x,y;//坐标 
	//int step;//步数 
}Point;
bool check(int x,int y){
	if(x<0 || y<0 || x>=n || y>=m || vis[x][y] || MAP[x][y]=='*'){
		return false;
	}
	return true;
}

void BFS(){
	queue<Node> q;
	Node now,next;
	q.push(Point);//加入队列最后 
	while(!q.empty()){
		now = q.front();//取队首元素 
		q.pop();
		
		for(int i=0; i<8; i++){
			next.x = now.x + dir[i][0];
			next.y = now.y + dir[i][1];
			
			if(check(next.x,next.y)){
				MAP[next.x][next.y] = '*';
				q.push(next);
				vis[next.x][next.y] = 1;
			}
		}
		
	}
}

int main(void)
{
	while(scanf("%d %d",&n,&m) && n && m){
		memset(MAP,0,sizeof(MAP));
		memset(vis,0,sizeof(vis));
		sum = 0;
		
		for(int i=0; i<n; i++){
			for(int j=0; j<m; j++){
				cin >> MAP[i][j];
			}
		}
		
		for(int i=0; i<n; i++){
			for(int j=0; j<m; j++){
				if(MAP[i][j] == '@' && vis[i][j] == false){
					sum++;
					Point.x = i;
					Point.y = j;
					vis[i][j] = 1;
					BFS();
				}
			}		
		}
		
		cout << sum << endl;
	}
	return 0;
}

/*模板 

struct node{坐标,步数} st 
check函数 
bfs{
	定义队列q
	定义当前状态 now 和下一个状态 next
	计数器清零
	q.push(st) 入队,在队尾加入元素 
	vis[st.x][st.y] = 1
	while(q.empty()){
		取队首元素进行扩展q.front()
		if(now出现目标态) 进行处理
		for(int i=0; i<方向数; i++{
			next = now.x + dir[i][0]
			...
			next.step = now.step + 1
			if(next满足约束条件check){q.push(next);vis[next.x][next.y] = 1} 
		} 
		q.pop();队首元素出队 
	}
}
 
*/
/*队列

empty()如果队列空则返回真
front()返回第一个元素
pop()删除第一个元素
push()在末尾加入一个元素
*/

改进之后:

#include <iostream>
#include <queue>
#include <cstring>

using namespace std;

const int N = 100;
char MAP[N+1][N+1];
bool vis[N+1][N+1]; 
int dir[8][2] = {{1,0},{-1,0},{0,1},{0,-1},{-1,-1},{-1,1},{1,1},{1,-1}};
int n,m,sum;

struct Node{
	int x,y;//坐标 
	//int step;//步数 
}Point;
bool check(int x,int y){
	if(x<0 || y<0 || x>=n || y>=m || vis[x][y] || MAP[x][y]=='*'){
		return false;
	}
	return true;
}

void BFS(){
	queue<Node> q;
	Node now,next;
	q.push(Point);//加入队列最后 
	while(!q.empty()){
		now = q.front();//取队首元素 
		q.pop();
		
		for(int i=0; i<8; i++){
			next.x = now.x + dir[i][0];
			next.y = now.y + dir[i][1];
			
			if(check(next.x,next.y)){
				//MAP[next.x][next.y] = '*';//已经有标记函数,就不需要多此一举了 
				q.push(next);
				vis[next.x][next.y] = 1;
			}
		}
		
	}
}

int main(void)
{
	while(scanf("%d %d",&n,&m) && n && m){
		memset(MAP,0,sizeof(MAP));
		memset(vis,0,sizeof(vis));
		sum = 0;
		
		for(int i=0; i<n; i++){
			for(int j=0; j<m; j++){
				cin >> MAP[i][j];
			}
		}
		
		for(int i=0; i<n; i++){
			for(int j=0; j<m; j++){
				if(MAP[i][j] == '@' && vis[i][j] == false){
					sum++;
					Point.x = i;
					Point.y = j;
					vis[i][j] = 1;
					BFS();
				}
			}		
		}
		
		cout << sum << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值