顺序表c++数据结构实验之栈四:括号匹配

数据结构实验之栈四:括号匹配

Time Limit: 1000MS Memory limit: 65536K

题目描述

 给你一串字符,不超过50个字符,可能包括括号、数字、字母、标点符号、空格,你的任务是检查这一串字符中的( ) ,[ ],{ }是否匹配。

输入

 输入数据有多组,处理到文件结束。

输出

 如果匹配就输出“yes”,不匹配输出“no”

示例输入

sin(20+10){[}]

示例输出

yesno
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#define sqmax 60
using namespace std;
typedef struct
{
    char*base;
    char *top;
    int sqsize;
} sq;
int init(sq &s);
void push(sq &s,char n);
char pop(sq &s);
int empty(sq &s);
int main()
{
    sq s;
    int l,i,f;
    char t[60];
    //while(cin>>t)
    while(gets(t)!=NULL)
        /***注��空格�认为2个串***/
    {
        init(s);
        f=0;
        l=strlen(t);
        for(i=0; i<l; i++)
        {
            if(t[i]=='('||t[i]=='['||t[i]=='{')
                push(s,t[i]);
            if(t[i]==')')
            {
                if(*s.top=='(')
                    pop(s);
                else
                    f=1;
            }
            if(t[i]==']')
            {
                if(*s.top=='[')
                    pop(s);
                else
                    f=1;
            }
            if(t[i]=='}')
            {
                if(*s.top=='{')
                    pop(s);
                else
                    f=1;
            }
        }
        if(!empty(s)||f==1)
            cout<<"no\n";
        else
        {
            cout<<"yes\n";
        }
    }


}
int init(sq &s)
{
    s.base=(char *)malloc(sqmax *sizeof(char));
    if(!s.base) exit(0);
    s.top=s.base-1;
    s.sqsize=sqmax;
    return 1;
}
void push(sq &s,char n)
{
    *++s.top=n;
}
char pop(sq &s)
{
    return *s.top--;
}
int empty(sq &s)
{
    if(s.top==s.base-1)
        return 1;
    else
        return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值