数据结构实验之二叉树三:统计叶子数

数据结构实验之二叉树三:统计叶子数

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

输入

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

输出

输出二叉树的叶子结点个数。

示例输入

abc,,de,g,,f,,,

示例输出

3
#include <iostream>
#include <algorithm>
using namespace std;
typedef struct node
{
    char data;
    struct node *lchild,*rchild;
}node, *tree;
int i,k;
char c[60];
int xiancreat(tree &t);
int leave(tree t);
int main()
{
    tree t;
    while(cin>>c)
    {
        i=0;
        k=0;
        xiancreat(t);
        leave(t);
        cout<<k<<endl;
    }
}
int xiancreat(tree &t)
{
    char a=c[i++];
    if(a==',')
        t=NULL;
    else
    {
    t=(tree)malloc(sizeof(node));
    if(!t) exit(0);
    t->data=a;
    xiancreat(t->lchild);
    xiancreat(t->rchild);
    }
    return 0;
}
int leave(tree t)
{
    if(t!=NULL)
    {
        if(t->lchild==NULL&&t->rchild==NULL)
        {
            k++;
        }
        leave(t->lchild);
        leave(t->rchild);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值