数据结构实验之二叉树七:叶子问题

数据结构实验之二叉树七:叶子问题

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

输入

  输入数据有多行,每一行是一个长度小于 50 个字符的字符串。

输出

  按从上到下从左到右的顺序输出二叉树的叶子结点。

示例输入

abd,,eg,,,cf,,,
xnl,,i,,u,,

示例输出

dfg
uli
注意 其实就是层次遍历的拓展,输出条件不同而已
#include <iostream>
#include <algorithm>
#include<queue>
using namespace std;
typedef struct node
{
    char data;
    struct node *lchild,*rchild;
} node,*tree;
char c[60];
int i;
int xiancreat(tree &t);
void leave(tree t);//注意由题意需层次遍历
int main()
{
    tree t;
    while(cin>>c)
    {
        i=0;
        xiancreat(t);
        leave(t);
        cout<<endl;
    }
}
int xiancreat(tree &t)
{
    char a;
    a=c[i++];
    if(a==',')
        t=NULL;
    else
    {
        t=(tree)malloc(sizeof(node));
        if(!t) exit(0);
        t->data=a;
        xiancreat(t->lchild);
        xiancreat(t->rchild);
    }
    return 0;
}
void leave(tree t)
{
    tree p=t;
    queue<tree>st;
    if(p)
        st.push(p);
    while(!st.empty())
    {
        p=st.front();
        if(p->lchild==NULL&&p->rchild==NULL)
        {
            cout<<p->data;
        }
        st.pop();
        if(p->lchild!=NULL)
            st.push(p->lchild);
        if(p->rchild!=NULL)
            st.push(p->rchild);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值