(POJ3126)Prime Path - BFS

                                                                                           Prime Path

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27738 Accepted: 15150

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033
1733
3733
3739
3779
8779
8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

题目分析:

题目大意就是给定两个四位数,这两个四位数第一个数字都不为0且两个数字都为素数,问从第一个数到第二个数,每次修改一个数且新得到的数为素数,问最少需要变几次。给定初始状态和结束状态,问最少的次数,很明显是BFS。每次可以变一个数,一共有四个位置可以变,每个位置可以选择0-9十个数(开头的数字不能为0),四个状态为一层,将每层入队,出队就和结束状态比较,满足就结束,不满足就将下一层入队。

代码:

#include<iostream>
#include<queue>
#include<cmath>
#include<string.h>
using namespace std;

struct node {
	int Num;
	int step;
	node(int n = 0, int s = 0) { Num = n; step = s; }
};

int N;
int s, e;
queue<node> q;
int visit[10001];
//判断是否为素数
bool is_prime(int n) {
	if (n == 0 || n == 1)return false;
	else if (n == 2 || n == 3)return true;
	else {
		for (int i = 2; i <= sqrt(n); i++)
		{
			if (n%i == 0) {
				return false;
			}
		}
		return true;
	}
}


void bfs() {
	node temp;
	int STEP, NUM;
	while (!q.empty()) {
		temp = q.front();
		q.pop();
		STEP = temp.step;
		NUM = temp.Num;
		//终止条件
		if (NUM == e) {
			cout << STEP << endl;
			return;
		}
		//开头第一个数字
		for (int i = 1; i <= 9; i = i + 2)
		{
			int t = NUM / 10 * 10 + i;
			if (t!=NUM&&!visit[t] && is_prime(t))
			{
				visit[t] = 1;
				q.push(node(t, STEP + 1));
			}
		}
		//第二个数字
		for (int i = 0; i <= 9; i ++)
		{
			int t = NUM / 100 * 100 + i*10+NUM%10;
			if (t!=NUM&&!visit[t] && is_prime(t))
			{
				visit[t] = 1;
				q.push(node(t, STEP + 1));
			}
		}
		//第三个数字
		for (int i = 0; i <= 9; i++)
		{
			int t = NUM / 1000 * 1000 + i * 100 + NUM % 100;
			if (t != NUM && !visit[t] && is_prime(t))
			{
				visit[t] = 1;
				q.push(node(t, STEP + 1));
			}
		}
		//第四个数字
		for (int i = 1; i <= 9; i++)
		{
			int t = i * 1000 + NUM % 1000;
			if (t != NUM && !visit[t] && is_prime(t))
			{
				visit[t] = 1;
				q.push(node(t, STEP + 1));
			}
		}
	}
	cout << "Impossible" << endl;
	return;
}

int main() {
	cin >> N;
	
	for (int i = 0; i < N; i++)
	{
		while (!q.empty())q.pop();
		cin >> s >> e;
		memset(visit, 0, sizeof(visit));
		visit[s] = 1;
		q.push(node(s,0));
		bfs();
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值