Farmer Bill's Problem

Time Limit: 1000msMemory Limit: 32768KB 64-bit integer IO format: %I64d Java class name: Main
Submit Status PID: 24433
Peter has n cigarettes. He smokes them one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.

How many cigarettes can Peter have?

Input
Input is a sequence of lines. Each line contains two integer numbers giving the values of n and k.

Output
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.

Sample Input
4 3
10 3
100 5
Sample Output
5
14
124

我感觉这题很是变态,我想了好长时间,都没想出什么意思,真的崩溃了

这里写代码片
这题我也是想了很长时间,还是做题少吧

 1. 

列表内容
----

#include <iostream>  
using namespace std;  
int main()  
{  
    int n,k;  
    int sum;  
    while(cin>>n>>k)  
    {  
        sum=n;  
        while(n>=k)  
        {  
            sum+=n/k;  
            n=n/k+n%k;  
        }  
        cout<<sum<<endl;  
    }  
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值