hdu 4786 Fibonacci Tree(2013年亚洲区域赛成都赛区 1006)最小生成树

Fibonacci Tree

 

Problem Description

  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )

 

 

Input

  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 105) and M(0 <= M <= 105).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).

 

 

Output

  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.

 

 

Sample Input

 

2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1

 

 

Sample Output

 

Case #1: Yes Case #2: No

 

 

这道题的思路我是看的题解,看到题解后才慢慢理解的,就是求出用最少的白边的生成树low和最多白边的生成树higt,如果有一个斐波那契数在他们之间(包含low和high)那么就正确,否则就错误

#include<bits/stdc++.h>
using namespace std;
const int N=100010;
int low,high,cnt,n,m,fib[N],father[N];
bool flag=false;
struct Edge
{
    int u;
    int v;
    int w;
} e[N];
void Fib()
{
    fib[1]=1;
    fib[2]=2;
    int i=2;
    while(fib[i]<=N)
    {
        i++;
        fib[i]=fib[i-1]+fib[i-2];
    }
}
void Init(int n)
{
    for(int i=1; i<=n; i++)
        father[i]=i;
}
bool comp(Edge x,Edge y)
{
    return x.w<y.w;
}
int Find(int x)
{
    if(x!=father[x])
        father[x]=Find(father[x]);//寻找父节点
    return father[x];
}
void Merg(int a,int b)
{
    int p=Find(a);
    int q=Find(b);
    if(p>q)
        father[p]=q;
    else
        father[q]=p;
}
void Kruskal (int n)
{
    flag=false;
    Fib(),cnt=1,low=0,high=0;
    for(int i=0; i<m; i++)
        if(Find(e[i].u)!=Find(e[i].v))
        {
            Merg(e[i].u,e[i].v);
            low+=e[i].w;
            cnt++;
        }
    if(cnt==n)
    {
        cnt=1;
        Init(n);
        for(int i=m-1; i>=0; i--)
        {
            if(Find(e[i].u)!=Find(e[i].v))
            {
                Merg(e[i].u,e[i].v);
                high+=e[i].w;
                cnt++;
            }
        }
        int j=1;
        while(fib[j]<low)
        {
            j++;
        }
        if(fib[j]<=high)
            flag=true;
    }
}
int main()
{
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        Init(n);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
        }
        sort(e,e+m,comp);
        Kruskal(n);
        if(flag)
            printf("Case #%d: Yes\n",T++);
        else
            printf("Case #%d: No\n",T++);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值