POJ 2184 Cow Exhibition(0-1背包,负化正)

Description
“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input
* Line 1: A single integer N, the number of cows

  • Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output
  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output
8

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

给出num(num<=100)头奶牛的S和F值(-1000<=S,F<=1000),要求在这几头奶牛中选出若干头,使得在其总S值TS和总F值TF均不为负的前提下,求最大的TS+TF值
可以把S当体积,F当价值做01背包。但是注意是S可为负,所以整体加100000,然后要注意DP顺序,S为负是要顺序,为正时逆序。
还有就是注意DP时的范围,凡是可能影响的都要包括。
参考:点击
代码

   #include<cstdio>
    #include<cstring>
    #include<stdlib.h>
    #include<ctype.h>
    #include<math.h>
    #include<stack>
    #include<queue>
    #include<map>
    #include<set>
    #include<fstream>
    #include<vector>
    #include<string>
    #include<iostream>
    #include<algorithm>
    #include<utility>
    #include<iomanip>
    #include<time.h>
    #include<iostream>
    #define lowbit(x) (x&-x)
    #define abs(x) ((x)>0?(x):-(x))
    using namespace std;
    typedef long long ll;
    const double Pi = acos(-1.0);
    const int N = 1e6+10, M = 1e3+20, mod = 1e9+7, inf = 2e9+10;
    const double e=2.718281828459 ;
    const double esp=1e-9;
    int dp[2*N];
    int t,n,V,k;
    struct node
    {
        int ts,tf;
    }a[110];//把ts当做体积,把tf当做价值
    int main()
    {
        std::ios::sync_with_stdio(false);
        std::cin.tie(0);
        while(cin>>n)
        {
            for(int i=0;i<n;i++)
                cin>>a[i].ts>>a[i].tf;
            for(int i=0;i<=200000;i++) dp[i]=-inf;
            dp[100000]=0;
            for(int i=0;i<n;i++)
            {
                if(a[i].ts>0)
                {
                    for(int j=200000;j>=a[i].ts;j--)
                    {
                        dp[j]=max(dp[j],dp[j-a[i].ts]+a[i].tf);
                    }
                }
                else
                {
                    for(int j=a[i].ts;j<=200000+a[i].ts;j++)
                    {
                        dp[j]=max(dp[j],dp[j-a[i].ts]+a[i].tf);
                    }
                }
            }
            int ans=0;
            for(int i=100000;i<=200000;i++)
            {
                if(dp[i]>=0)
                    ans=max(ans,(dp[i]+i-100000));
            }
            cout<<ans<<endl;
        }
        return 0;
    }



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值