hdu 1024 Max Sum Plus Plus(K个最大连续子序列和)

未优化的K个最大连续子序列和,时间复杂度O(n^3) ,动态转移方程
dp[i,j]=max{dp[i,j-1]+a[j],dp[i-1,k]+a[j]} (i-1<=k<=j-1)

#include<iostream>
using namespace std;
int a[1001];
int dp[11][1001];
int main()
{
    int n,k,temp,Max;
    cin>>n>>k;
    for(int i=1;i<=n;i++) cin>>a[i];
    for(int i=1;i<=k;i++)
    {
        for(int j=1;j<=n;j++)
        {
            dp[i][j]=dp[i][j-1]+a[j];
            for(int m=i-1;m<=j-1;m++)
            {
                temp=dp[i-1][m]+a[j];
                if(temp>dp[i][j])
                    dp[i][j]=temp;
            }
        }
    }
    Max=dp[k][k];
    for(int i=k;i<=n;i++) Max=max(Max,dp[k][i]);
    cout<<Max<<endl;
    return 0;
}

Problem Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output
6
8

Hint

Huge input, scanf and dynamic programming is recommended.

为了不超时,不超内存,这个是优化后的代码

#include<cstdio>
#include<cstring>
#include<stdlib.h>
#include<fstream>
#include<ctype.h>
#include<math.h>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<string>
#include<iostream>
#include<algorithm>
#include<utility>
#include<iomanip>
#include<time.h>
#include<iostream>
#define lowbit(x) (x&-x)
#define abs(x) ((x)>0?(x):-(x))
using namespace std;
typedef long long ll;
const double Pi = acos(-1.0);
const int N = 1e6+10, M = 1e3+20, mod = 1e9+7, inf = 2e9+10;
const double e=2.718281828459 ;
const double esp=1e-9;
int m,n,temp;
int a[N];
int f[N],dp[N];
int main()
{
    // freopen("in.txt","r",stdin);    freopen("out.txt","w",stdout);
    std::ios::sync_with_stdio(false);
    std::cin.tie(0);
    while(cin>>m>>n)
    {
        memset(f,0,sizeof(f));
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++) cin>>a[i];
        for(int i=1; i<=m; i++)
        {
            temp=-inf;
            for(int j=i; j<=n; j++)
            {
                f[j]=max(f[j-1]+a[j],dp[j-1]+a[j]);
                dp[j-1]=temp;
                temp=max(temp,f[j]);
            }
        }
        cout<<temp<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值