hud 1724 求椭圆的面积(自适应辛普森)

Problem Description
Math is important!! Many students failed in 2+2’s mathematical test, so let’s AC this problem to mourn for our lost youth…
Look this sample picture:

A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PIab )

Input
Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation , A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).

Output
For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.

Sample Input
2
2 1 -2 2
2 1 0 2

Sample Output
6.283
3.142

参考博客:http://blog.csdn.net/u010527492/article/details/17106487

AC代码:


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<string>
using namespace std;
const double Eps=1e-6;
 double a,b,l,r;
double f(double x)
{
    return b*sqrt(1.0-x*x/(a*a));
}
double simpson(double l,double r)
{
    double mid=l+(r-l)/2.0;
    return (r-l)*(f(l)+4.0*f(mid)+f(r))/6.0;
}
double solve(double l,double r,double esp)
{
    double  mid=l+(r-l)/2.0;
    if(fabs(simpson(l,r)-simpson(l,mid)-simpson(mid,r))<esp)
        return simpson(l,r);
    else return solve(l,mid,esp/2)+solve(mid,r,esp/2);
}
int main()
{
    int t;
  //  double a,b,l,r;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf",&a,&b,&l,&r);
          printf("%.3lf\n",2*solve(l,r,Eps));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值