POJ~1077~八数码~A*解题报告

八数码:

题目描述:

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 
 1  2  3  4 

 5  6  7  8 

 9 10 11 12 

13 14 15  x 

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4    1  2  3  4    1  2  3  4    1  2  3  4 

 5  6  7  8    5  6  7  8    5  6  7  8    5  6  7  8 

 9  x 10 12    9 10  x 12    9 10 11 12    9 10 11 12 

13 14 11 15   13 14 11 15   13 14  x 15   13 14 15  x 

           r->           d->           r-> 

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement. 

Input:

You will receive a description of a configuration of the 8 puzzle. The description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x’. For example, this puzzle
1 2 3

x 4 6

7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

Output:

You will print to standard output either the word ``unsolvable’’, if the puzzle has no solution, or a string consisting entirely of the letters ‘r’, ‘l’, ‘u’ and ‘d’ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line.。

Sample Input:

 2  3  4  1  5  x  7  6  8 

Sample Output:

ullddrurdllurdruldr

题目大意:

其实这道题很简单理解,就是简单的九宫格排序问题,而只能移动上下左右这四个方向,并且还要满足1 2 3 4 5 6 7 8 x这样的排序即可,所以这道题可以用A*+康托定理去解。

思路分析:

这道题方向很简单,但是要实施起来有点困难,这里有很多种解法,类似BFS和双BFS,这里讲一下A*去解这道题,这道题它只需要将九宫格的数字,按顺序排序好就行,那么我们可以这样认为每一个数字到达属于它宫格所需要的代价为h,那么九个全部移动下来是H,这里我们可以将其看做是启发式函数(就是到达目的预估需要代价,这里是预估),因为这里是一个九宫格只有横竖,那么可以用曼哈顿函数来去代替它,那么实际移动只能一次只能移动一次,可以认为G(直接运动代价),那么可以得到公式实际运动代价为F=G+H,只要F为最小,说明所耗费的时间与代价也最小(所要运行的时间少,效率快)。以及当它的排序达到目的即为答案。这里解释相关原理:

曼哈顿距离:这里因为是九宫格,所以可以用2点坐标的绝对值差来表示所需要的代价,|x1-x2|+|y1-y2|这里即为上述所讲的h,将所有h相加即为H。
康托定理:
X=a[n]*(n-1)!+a[n-1]*(n-2)!+...+a[i]*(i-1)!+...+a[1]*0!,
其中a[i]为当前未出现的元素中是排在第几个(从0开始)。这就是康
托展开
1. 举个简单的例子吧,例如(1234)这四种数字全排列,如果要
求2134的排在全排列第几个,可以这样算:
2. 首位是2,比他小的有1,那么就有1*4-1)!。
3. 第二位是1,没有比他小,那么就有0*4-2)!。
4. 第三位是3,比他小的有 12,但是12都已经出现在前面了,所以
   0*4-3!
5. 第四位是4,比他小的有123,但是都出现在前面,所以有0*(0)!
6. 最后将其全部相加就是该数字在全排列中的排序。

代码:

#include<iostream>
#include<cstdio>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<algorithm>
#include<vector>
#include<cmath>
#include<string.h>
#define me(a,b) memset((a),(b),sizeof((a)))//定义memset形式 
using namespace std;
const int maxn=363000;//因为只计算!9的阶级 
const int ATM=1;// 123456789的Hash的值 
int di1[5][2]={{1,0},{-1,0},{0,1},{0,-1}};//方向变量 
char di2[5]={"durl"};//方向变量 
char pr[maxn];//存储方向变量 
int pre[maxn];//存储父子点 
int visit[maxn];//标记是否访问过 
int fc[]={1,1,2,6,24,120,720,5040,40320,362880}; //0~9的阶乘 
typedef struct Node
{
	int c1[10];//记录九宫格元素 
	int num;//记录Hash值 
	int ans;//记录位置 
	int g,h,f; 
	bool operator<(const Node x)const//改变优先队列的弹出方式 
	{
		return f>x.f;//f表示当前值 
	 }//该方式是优先弹出小的 
}Lemon;
priority_queue<Lemon> q;//创建优先队列 
int dis(int s[])//找到曼哈顿值 
{
	int sum=0;
	for(int i=0;i<9;i++)
	{
		if(s[i]!=9)//这里不能为9,如果为9,无法继续扩展下去。 
		{
			int x = i/3, y = i%3;
        int x1 = (s[i]-1)/3, y1 = (s[i]-1)%3;
        sum += abs(x-x1) + abs(y-y1);
		}
	}
	return sum;
}
int Hash(int s1[])//康托定理正向解密 
{
	int sum=1;
	for(int i=0;i<9;i++)
	{
		int temp=0;
		for(int j=i+1;j<9;j++)
		{
			if(s1[j]<s1[i])
			{
				temp++;
			}
		}
		sum+=temp*fc[9-i-1];
	}
	return sum;
}
int LemonBFS(Lemon Frist)//BFS搜索 
{
	Lemon now;
	me(visit,0);
	visit[Frist.num]=1;//标记该点Hash值已经找过 
	pre[Frist.num]=-1;//设置根为-1 
	Frist.g=0;
	Frist.h=dis(Frist.c1);
	Frist.f=Frist.g+Frist.h;
	q.push(Frist);
	while(!q.empty())
	{
		now=q.top();
		q.pop();
		if(now.num==ATM)//如果Hash值等于1,说明已经找到123456789了可以退出 
		{
			return 1;
		}
		int x=now.ans/3;
		int y=now.ans%3;
		//找位置 
		for(int i=0;i<4;i++)
		{
			Lemon tp=now;
			int x1=x+di1[i][0];
			int y1=y+di1[i][1];
			if(x1<0 || y1<0 || x1>2 || y1>2)//判断边界 
			continue;
			else
			{
				tp.ans=x1*3+y1;
				tp.c1[now.ans]=tp.c1[tp.ans];
				tp.c1[tp.ans]=9;
				//交换元素 
				tp.num=Hash(tp.c1);
				if(!visit[tp.num])
				{
					visit[tp.num]=1;
					tp.g++;//g值 
					tp.h=dis(tp.c1);//找h值 
					tp.f=tp.h+tp.g;//f值 
					pre[tp.num]=now.num;//记录父子点 
					pr[tp.num]=di2[i];//记录方向操作 
					q.push(tp);//入队 
				}
			}
		}
	}
	return 0;
}
void print(int ATM)
{
	if(pre[ATM]==-1)//当等于-1说明到达了根了,可以回溯了 
	{
		return;
	}
	else
	{
	  print(pre[ATM]);//递归 
	  cout << pr[ATM];	
	}
}
int main()
{
	Lemon Frist;
	char ch;
	for(int i=0;i<9;i++)
	{
		cin >> ch;
		if(ch=='x')
		{
			Frist.c1[i]=9;
			Frist.ans=i;
		}
		else
		{
			Frist.c1[i]=ch-'0';
		}
	}
	Frist.num=Hash(Frist.c1);
	if(!LemonBFS(Frist))//输出 
	{
		cout << "unsolvable";
	}
	else
	{
		print(ATM);
	}
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这是一道比较经典的计数问题。题目描述如下: 给定一个 $n \times n$ 的网格图,其中一些格子被标记为障碍。一个连通块是指一些被标记为障碍的格子的集合,满足这些格子在网格图中连通。一个格子是连通的当且仅当它与另一个被标记为障碍的格子在网格图中有公共边。 现在,你需要计算在这个网格图中,有多少个不同的连通块,满足这个连通块的大小(即包含的格子数)恰好为 $k$。 这是一道比较经典的计数问题,一般可以通过计算生成函数的方法来解决。具体来说,我们可以定义一个生成函数 $F(x)$,其中 $[x^k]F(x)$ 表示大小为 $k$ 的连通块的个数。那么,我们可以考虑如何计算这个生成函数。 对于一个大小为 $k$ 的连通块,我们可以考虑它的形状。具体来说,我们可以考虑以该连通块的最左边、最上边的格子为起点,从上到下、从左到右遍历该连通块,把每个格子在该连通块中的相对位置记录下来。由于该连通块的大小为 $k$,因此这些相对位置一定是 $(x,y) \in [0,n-1]^2$ 中的 $k$ 个不同点。 现在,我们需要考虑如何计算这些点对应的连通块是否合法。具体来说,我们可以考虑从左到右、从上到下依次处理这些点,对于每个点 $(x,y)$,我们需要考虑它是否能够与左边的点和上边的点连通。具体来说,如果 $(x-1,y)$ 和 $(x,y)$ 都在该连通块中且它们在网格图中有公共边,那么它们就是连通的;同样,如果 $(x,y-1)$ 和 $(x,y)$ 都在该连通块中且它们在网格图中有公共边,那么它们也是连通的。如果 $(x,y)$ 与左边和上边的点都不连通,那么说明这个点不属于该连通块。 考虑到每个点最多只有两个方向需要检查,因此时间复杂度为 $O(n^2 k)$。不过,我们可以使用类似于矩阵乘法的思想,将这个过程优化到 $O(k^3)$ 的时间复杂度。 具体来说,我们可以设 $f_{i,j,k}$ 表示状态 $(i,j)$ 所代表的点在连通块中,且连通块的大小为 $k$ 的方案数。显然,对于一个合法的 $(i,j,k)$,我们可以考虑 $(i-1,j,k-1)$ 和 $(i,j-1,k-1)$ 这两个状态,然后把点 $(i,j)$ 加入到它们所代表的连通块中。因此,我们可以设计一个 $O(k^3)$ 的 DP 状态转移,计算 $f_{i,j,k}$。 具体来说,我们可以考虑枚举连通块所包含的最右边和最下边的格子的坐标 $(x,y)$,然后计算 $f_{x,y,k}$。对于一个合法的 $(x,y,k)$,我们可以考虑将 $(x,y)$ 所代表的点加入到 $(x-1,y,k-1)$ 和 $(x,y-1,k-1)$ 所代表的连通块中。不过,这里需要注意一个细节:如果 $(x-1,y)$ 和 $(x,y)$ 在网格图中没有相邻边,那么它们不能算作连通的。因此,我们需要特判这个情况。 最终,$f_{n,n,k}$ 就是大小为 $k$ 的连通块的个数,时间复杂度为 $O(n^2 k + k^3)$。 参考代码:

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值