Conscription(最大生成树)

Windy需要组建军队,为此他选择了N个女孩和M个男孩。每个士兵的征集成本为10000 RMB,但如果女孩x和男孩y有关系d,他们中的一人被选中后,另一人的征集成本会减少到10000-d RMB。任务是找到征集所有士兵的最低总成本。这个问题可以转化为求解最大优惠的最小生成树问题。
摘要由CSDN通过智能技术生成
poj3723

Time Limit:
 1000MS
 Memory Limit: 65536K
Total Submissions: 15731 Accepted: 5437

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

n个女生,m个男生,r对认识的男女。每个进部队的人要交10000元,如果某对男女认识的话,且其中有一位一进部队,则另一位可以减x的费用,一个人只能拉进来一个关系户。

进去一个人就找与当前这个森林优惠最大的点,最小生成树一个道理,这是每次找与树最远的点。(这道题并不是每个点都能入树)。用(n+m)*10000-ans(最大优惠)

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
#define maxn 50005
struct node
{
    int x;
    int y;
    int value;
}edge[50005];
int f[maxn];
bool cmp(node a,node b)
{
    return a.value>b.value;
}
int found(int x)
{//路径压缩,否则超时
    if(x!=f[x])
        f[x]=found(f[x]);
    return f[x];
}
bool combine(int x,int y)
{
    int tx=found(x);
    int ty=found(y);
    if(tx==ty) return false;
     f[tx]=ty; return true;
}
int main()
{
    int t,n,m,r;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&r);
        ///共n个女生,m个男生,r个关系
         int num=0;
         int sum=0;
         memset(f,0,sizeof(f));
         memset(edge,0,sizeof(edge));
        for(int i=0;i<r;i++)
        {
            int b;
            scanf("%d%d%d",&edge[i].x,&b,&edge[i].value);
            edge[i].y=b+n;//bian hao
        }
        for(int i=0;i<=m+n-1;i++)
            f[i]=i;
        sort(edge,edge+r,cmp);
        for(int i=0;i<r;i++)
        {
//          if(num==n+m-1) break;并不是所有点都可以连进去,所以不用判断这个
            if(combine(edge[i].x,edge[i].y))
            {
                num++;
                sum+=edge[i].value;
            }
        }
            printf("%d\n",(n+m)*10000-sum);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值