hdu6441 Find Integer勾股数

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1666    Accepted Submission(s): 579
Special Judge

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

Sample Input

1 2 3

Sample Output

4 5

 

费马大定理 


1. a^n+b^n=c^n,n>2时无解。 

 


2. 当a为奇数时, 
a=2⋅k+1

c=k^2+(k+1)^2

b=c−1

当 a为偶数

a=2∗k+2

c=1+(k+1)^2

b=c−2

#include<bits/stdc++.h>
using namespace std;
const int maxn=500100;
typedef long long ll;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,a;
        scanf("%d%d",&n,&a);
        if(n==0||n>2)
        {
            printf("-1 -1\n");
            continue;
        }
        if(n==1)
        {
            printf("1 %lld\n",a+1);
            continue;
        }
        if(a%2)//a是奇数
        {
            int k=(a-1)/2;
            ll b=2*k*k+2*k;
            ll c=b+1;
            printf("%lld %lld\n",b,c);
        }
        else//a偶数
        {
            int k=(a-2)/2;
            ll c=k*k+2*k+2;
            ll b=c-2;
            printf("%lld %lld\n",b,c);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值