Anohana: The Flower We Saw That Day

Problem Description

我们仍未知道那天所看见的花的名字

 

Which day is it? Menma has forgotten lots of things and she can only vaguely remember a date.

Now you need to decide whether a date can be a possible date in Menma's memory.

Input

The input contains only 3 integers separated by spaces in one line, denoting the year, month and day of the date.

Output

If the date can be a possible date, output "Super Peace Busters" in one line and output "Jinta" else (without quotes).

Example Input
2016 11 12
Example Output
Super Peace Busters
Hint

Only when a date is a valid date, can it be possible.

For example, 2015 2 29 is impossible.


源代码

#include<stdio.h>
int main()
{
	int year,month,day,a;
	scanf("%d%d%d",&year,&month,&day);
	if(month>12||month<=0) printf("Jinta");
	else 
	{
		switch(month)
		{
			case 1:
			case 3:
			case 5:
			case 7:
			case 8:
			case 10:
			case 12:
			    {
			        if(day>31||day<=0) printf("Jinta");
			        else printf("Super Peace Busters");
			        break;
					}
			case 4:
			case 6:
			case 9:
			case 11:
				{
					if(day>30||day<=0)printf("Jinta");
					else printf("Super Peace Busters");
					break;
				}
			case 2:
				{
					if((year%400==0)||(year%100!=0&&year%4==0))
					{
						if(day<=29||day<=0) printf("Super Peace Busters");
						else printf("Jinta");
					}
					else 
					{
						if(day<=28||day<=0) printf("Super Peace Busters");
						else printf("Jinta");
					}
				}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值