C - TheTriangle

                         C - TheTriangle

                                                             时间限制:1秒 内存限制:128兆


题目描述

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.


输入

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.


输出

Your program is to write to standard output. The highest sum is written as an integer.

样例输入

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5


样例输出

30


#include<iostream>
using namespace std;
int max(int a,int b)
{return a>b?a:b;}
int s[105][105];
int main()
{
	int n,i,j;
	cin>>n;
	for(i=0;i<n;i++)
	for(j=0;j<=i;j++)
	cin>>s[i][j];
	
	for(i=n-2;i>=0;i--)
	for(j=0;j<i+1;j++)
	s[i][j]+=max(s[i+1][j],s[i+1][j+1]);
	cout<<s[0][0];
}




                       单调递增最长子序列

                                                              时间限制:3秒 内存限制:128兆


题目描述
求一个字符串的最长递增子序列的长度
如:dabdbf最长递增子序列就是abdf,长度为4

输入

第一行一个整数0<n<20,表示有n个字符串要处理
随后的n行,每行有一个字符串,该字符串的长度不会超过10000

输出

输出字符串的最长递增子序列的长度


样例输入

3
aaa
ababc
abklmncdefg


样例输出

1
3
7


#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
char s[10005];
int dp[10005];
int main()
{
	int t,n,i,j,len;
	cin>>t;
	while(t--)
	{
		cin>>s;
		len=strlen(s);
		for(i=0;i<len;i++)
		dp[i]=1;
		for(i=1;i<len;i++)
		for(j=0;j<i;j++)
		if(s[i]>s[j]&&dp[i]<dp[j]+1)
		dp[i]=dp[j]+1;
		
		sort(dp,dp+len);
		cout<<dp[len-1]<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值