输入年份和月份 判断该月有多少天(C语言)

描述:

输入年份和月份,输出该月份有多少天。

输入:

在一行中输入两个整数year(year>0)和month(1≤month≤12),分别表示年份和月份。

输出:

在一行中按格式“Days of the month is ××”输出一个整数,即该月份的天数。

输入样例 1:2020 5

输出样例 1:Days of the month is 31

输入样例 2:2020 2

输出样例 2:Days of the month is 29

#include <stdio.h>
int main()
{
	int year, month;
	scanf("%d %d", &year, &month);
	if (month==2) {
		if ( year%4==0&&year%100!=0 || year%400==0 ) 
			printf("Days of the month is 29");
		else 	
			printf("Days of the month is 28");
	} else if ( month==1 || month==3 || month==5 || month==7 || month==8 || month==10 || month==12 ) 
		printf("Days of the month is 31");
	else 
		printf("Days of the month is 30");
		
	return 0;	
} 

  • 10
    点赞
  • 21
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值