1044. Shopping in Mars (25)

1044. Shopping in Mars (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

 
 

16 15 3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

 
 

1-5 4-6 7-8 11-11

Sample Input 2:

 
 

5 13 2 4 5 7 9

Sample Output 2:

 

 
 

2-4 4-5


这道题要卡时间复杂度,一开始自己写的两个循环遍历查找,有三个测试点运行超时。缩短查找时间的有效方法是二分查找,但二分查找要求有序的序列,一个小的技巧是,对序列进行累加,得到每个位置与起点间的和,这样就得到了一个递增的序列。再对起点进行进行遍历,对终点进行二分查找。
参考的网上的一种做法

#include<iostream> #include<vector> void FindBest(std::vector<int>& sum, int m, int i, int& j, int& tmpSum) { int l = i; int r = (int)sum.size()-1; while(l < r) { int mid = (l+r)/2; if(sum[mid]-sum[i-1] >= m)
r = mid; else l = mid+1; } j = r; tmpSum = sum[j]-sum[i-1]; } int main() { int n, m; while(scanf("%d%d",&n,&m)!=EOF) { std::vector<int> sum; sum.assign(n+1, 0); for(int i = 1; i <= n; ++i) { scanf("%d",&sum[i]); sum[i] = sum[i-1]+sum[i]; }
std::vector<std::pair<int,int>> so; //简单的结构体可以这样处理,不用再定义结构体 int best = -1; for(int i = 1; i <= n; ++i) { int j, tmpSum; FindBest(sum, m, i, j, tmpSum);//没有返回值,使用引用,当需要返回多个值,可以这样处理 if(best == -1 || (tmpSum < best && tmpSum >= m)) { best = tmpSum; so.clear(); so.push_back(std::make_pair(i,j)); } else if(best != -1 && tmpSum == best) { so.push_back(std::make_pair(i,j)); } } //output for(int i = 0; i < so.size(); ++i) printf("%d-%d\n",so[i].first, so[i].second); } return 0; }
自己之前的代码
#include<iostream>
#include<fstream>
#include<string>
#include<algorithm>
#include<vector>
using namespace std;
#define inf 10000000
struct NODE
{
	int b;
	int e;
	bool operator<(const NODE& t)const
	{
		return b < t.b;
	}
};
int main()
{
	//ifstream fin("Text.txt");
	int N, M;
	cin >> N >> M;
	int i, j,len;
	vector<int>seq(N);
	vector<NODE>res;
	for (i = 0; i < N; i++)
		cin >> seq[i];
	int Min = inf,sum=0;
	for (len = 1; len <= N; len++)
	{
		for (i = 0; i + len - 1 < N; i++)
		{
			sum = 0;
			for (j = i; j <= i + len - 1; j++)
				sum += seq[j];
			j--;
			if (sum >= M)
			{
				if (sum - M < Min)
				{
					res.clear();
					NODE t;
					t.b = i + 1;
					t.e = j + 1;
					res.push_back(t);
					Min = sum - M;
				}
				else if (sum - M == Min)
				{
					NODE t;
					t.b = i + 1;
					t.e = j + 1;
					res.push_back(t);
				}
				else;



			}
		}
	}
	sort(res.begin(), res.end());
	for (i = 0; i < res.size(); i++)
		cout << res[i].b << "-" << res[i].e << endl;

	
	return 0;

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值