1049. Counting Ones (30)
时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.
Input Specification:
Each input file contains one test case which gives the positive N (<=230).
Output Specification:
For each test case, print the number of 1's in one line.
Sample Input:12Sample Output:
5
这道题最开始自己是用递推的方法来做,答案没有问题,但时间和空间复杂度过不了。后来认为可以按所在位拆分计算,然后分该位大于1,等于1,小于1三种情况去讨论;
贴两个代码。
自己递推方法:
#include<iostream>
#include<fstream>
#include<string>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
int N;
//ifstream fin("Text.txt");
cin >> N;
int i, j,k;
//int* one = new int[N+1] {0};//one[i]=j表示i有j个1
int last=0;
for (i = 1; i <= N; i++)
{
j = 0; k = i;
while (k > 0)
{
if (k % 10 == 1)j++;
k = k / 10;
}
//one[i] = one[i - 1] + j;
last=last+j;
}
cout << last << endl;
return 0;
}
参考分类讨论:
#include<stdio.h>
int CountOnes(int n){
int count = 0;
int factor = 1;
int higher,lower,cur;
while(n/factor != 0){
higher = n/(factor*10);
lower = n - (n/factor)*factor;
cur = (n/factor)%10;
switch (cur){
case 0:
count += higher*factor;
break;
case 1:
count += higher*factor + lower +1;
break;
default:
count += higher*factor + factor;
}
factor = factor * 10;
}
return count;
}
int main()
{
int n;
scanf("%d",&n);
printf("%d\n",CountOnes(n));
return 0;
}