1048. Find Coins (25)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.
Sample Input 1:8 15 1 2 8 7 2 4 11 15Sample Output 1:
4 11Sample Input 2:
7 14 1 8 7 2 4 11 15Sample Output 2:
No Solution
这道题自己的做法是对输入序列进行排序,遍历第一枚硬币的值,再使用二分查找第二枚硬币的值,这个方法是可行的,但代码有两个点答案错误。参考的做法是使用hash表,用空间去换查找效率。
贴两种代码。
遍历+二分查找
#include<iostream>
#include<fstream>
#include<string>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
#define inf 10000000
vector<int>seq;
int N, M;
bool Find(int data, int left, int right)
{
if (left > right)return false;
else if (left == right)
{
if (seq[data] + seq[left] == M)return true;
else return false;
}
int mid = (left + right) / 2;
if (seq[data] + seq[mid] == M)return true;
else if (seq[data] + seq[mid] > M)return Find(data, left, mid-1);
else return Find(data, mid+1, right);
}
int main()
{
//ifstream fin("Text.txt");
int i,j,k,tmp;
cin >> N >> M;
seq.resize(N);
for (i = 0; i < N; i++)
cin >> seq[i];
sort(seq.begin(), seq.end());
k = 0;
for (i = 0; i < N-1; i++)
{
if (Find(i, i + 1, N - 1))
{
k = 1; break;
}
}
if (k == 0)cout << "No solution" << endl;
else cout << seq[i] << " " << M - seq[i] << endl;
//cin.get();
return 0;
}
hash表
#include<iostream>
#include<string.h>
using namespace std;
#define max 100000
int input[max];
int main()
{
int N,M;
cin>>N>>M;
int i,j;
int temp;
int flag;
bool find = false;
memset(input,0,sizeof(input));
for(i=0; i<N; i++)
{
cin>>temp;
input[temp] ++;
}
for(i=0; i<=M/2; i++)
{
//以下两行是为了判断是否存在两个同样的数和为题目所求,比如14=7+7;
input[i]--;
input[M-i]--;
if(input[i]>=0 && input[M-i]>=0)
{
find = true;
cout<<i<<" "<<M-i<<endl;
break;
}
}
if( !find )
cout<<"No Solution"<<endl;
return 0;
}