Perfect Pth Powers解题报告

Description

We say that x is a perfect square if, for some integer b, x = b2. Similarly, x is a perfect cube if, for some integer b, x = b3. More generally, x is a perfect pth power if, for some integer b, x = bp. Given an integer x you are to determine the largest p such that x is a perfect pth power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect pth power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2
#include<stdio.h>
#include<math.h>
int main()
{
	double n,b;
	long x,y;
	int i;
	while(scanf("%lf",&n)!=EOF)
	{
		if(n==0)
			break;
		if(n>0)
		{
			for(i=32;i>=0;i--)
			{
				b=pow(n,1.0/i);
				x=b;    //类型转换为long
				y=x+1;  //
				if(b-x<=1e-12||y-b<=1e-12)
				{
					printf("%d\n",i);
					break;
				}
			}
		}
		if(n<0)
		{
			n=-n;  //if n《0,先转化为正数先,然后i 只能为奇数,查找i。
			for(i=31;i>=1;i-=2)
			{
				b=pow(n,1.0/i);
				x=b;      //类型转换为long。
				y=x+1;    //
				if(b-x<=1e-12||y-b<=1e-12)
				{
					printf("%d\n",i);
					break;
				}
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值