ZOJ 3203 计算几何+三分

//链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3366

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house.Every night, he is wandering in his incommodious house, thinking of how to earn more money.One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house.A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.


Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line.H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall.All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000


昨天才学习了三分技术,今天就找了到三分的题目来练练手。

这道题目的感觉还不撮,写完之后,调试了下,过了样例直接就交了。

果断的1Y。


我的代码:

#include<stdio.h>
#include<algorithm>
#include<math.h>
#define eps 1e-8

using namespace std;

double dx,H,h,D;

double cul(double x){
	double ret,t1,t2,k,l;
	if(x<=dx)
	{
		ret=h*x/(H-h);
		return ret;
	}
	else
	{
		t1=D-x;
		k=h*x/(H-h);
		l=k-(D-x);
		t2=H*l/(l+D);
		ret=t1+t2;
		return ret;
	}
}

int main(){
	int t,i;
	double l1,l2;
	double mid1,mid2,left,right;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf%lf%lf",&H,&h,&D);
		dx=D-h*D/H;
		left=0,right=D;
		for(i=1;i<=100;i++)
		{
			mid1=(left*2+right)/3;
			mid2=(left+right*2)/3;
			l1=cul(mid1);
			l2=cul(mid2);
			if(l1>l2)
			{
				right=mid2;
			}
			else
			{
				left=mid1;
			}
		}
		printf("%.3lf\n",cul(left));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值