HDOJ/HDU 3877 Special sort

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3877



Problem Description
We all know a+b=c,but now there is a new rule in equations:
if a>b,then it's equal to [>c];
if a=b,then it's equal to [=c];
if a<b,then it's equal to [<c];
a sample:

1+1=[=2]
2+0=[>2]
0+2=[<2]
1+2=[<3]

and [>c] > [=c] > [<c].
For every [n],
[n+1] > [n] >[n-1].
 

Input
The input consists of T cases.The first line of the input contains only positive integer T (0<T<=100).Then follows the cases.Each case begins with a line containing exactly one integer N (0<N<=10000).Then there are N lines, each with two integers a and b (0<a,b<2^31-1).
 

Output
For each case, calculate each value of a+b(as a+b=[?]) and output a+b=[?] in descending order sorted by [?]. If there exists some pair of a,b whose order can not be determined by the rules above, output them with the order of the input. A blank line should be printed after each case.
 

Sample Input
  
  
2 5 1 5 5 1 3 3 4 5 5 6 5 1 6 6 1 2 4 4 2 3 3
 

Sample Output
  
  
5+6=[<11] 4+5=[<9] 5+1=[>6] 3+3=[=6] 1+5=[<6] 6+1=[>7] 1+6=[<7] 4+2=[>6] 3+3=[=6] 2+4=[<6]
 

Source


题目意思很简单。。而且也不是太难。

但是悲剧的我却WA了好多次都不知道怎么办。最后才知道原来要用long long才能装得下啊。。

至于排序么,我没有再去加以个变量记录他的位子,我比较懒,直接用stable_sort水过去了。


我的代码:

#include<stdio.h>
#include<algorithm>
typedef long long ll;

using namespace std;

struct node
{
    ll a;
    ll b;
    ll ans;
    ll level;
};
node E[10005];

bool cmp(node x,node y)
{
    if((x.ans>y.ans)||(x.ans==y.ans&&x.level>y.level))
        return true;
    return false;
}

int main()
{
    ll t,n,i;
    scanf("%I64d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%I64d%I64d",&E[i].a,&E[i].b);
            E[i].ans=E[i].a+E[i].b;
            if(E[i].a>E[i].b)
                E[i].level=3;
            else if(E[i].a==E[i].b)
                E[i].level=2;
            else
                E[i].level=1;
        }
        stable_sort(E+1,E+1+n,cmp);
        for(i=1;i<=n;i++)
        {
            if(E[i].level==3)
                printf("%I64d+%I64d=[>%I64d]\n",E[i].a,E[i].b,E[i].ans);
            if(E[i].level==2)
                printf("%I64d+%I64d=[=%I64d]\n",E[i].a,E[i].b,E[i].ans);
            if(E[i].level==1)
                printf("%I64d+%I64d=[<%I64d]\n",E[i].a,E[i].b,E[i].ans);
        }
        printf("\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值