HDU/HDOJ 1299 Diophantus of Alexandria

 

Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 856    Accepted Submission(s): 326


Problem Description
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles.

Consider the following diophantine equation:

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)


Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:

1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4



Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?
 

Input
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).
 

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line.
 

Sample Input
  
  
2 4 1260
 

Sample Output
  
  
Scenario #1: 3 Scenario #2: 113
 

Source
 

Recommend
JGShining
 

 

这个题个人感觉不难,属于比较基础的数论了吧。。

我是这样思考的:

可以假设x=n+k

那么问题变为了1/n-1/(n+k)有多少分子为1的可能情况

化下简:k/(n*(n+k))-------->k/(n^2+nk)

那么分子要为1,必然的,分母一定是k的倍数

而注意到nk一定是k的倍数,所以关键还是看n^2

那么问题进一步转化为有多少k可以整除n^2

在说白一点,就是求n^2的约数个数。

但是由于这个题要求了x<=y所以最后求出来的约束个数要+1在除以2

 

我的代码:

#include<stdio.h>
#include<math.h>
#include<string.h>

int prime[40000];
bool flag[40000];

void init()
{
	__int64 i,j,num=0;
	for(i=2;i<40000;i++)
	{
		if(!flag[i])
		{
			prime[num++]=(int)i;
			for(j=i*i;j<40000;j=j+i)
				flag[j]=true;
		}
	}
}

void solve(int n,int CASE)
{
	int i;
	int fac[100],num=0;
	memset(fac,0,sizeof(fac));
	for(i=0;prime[i]*prime[i]<=n;i++)
	{
		if(n%prime[i]==0)
		{
			n=n/prime[i];
			num++;
			fac[num]++;
			while(n%prime[i]==0)
			{
				n=n/prime[i];
				fac[num]++;
			}
		}
		if(n==1)
			break;
	}
	if(n>1)
	{
		num++;
		fac[num]++;
	}
	for(i=1;i<=num;i++)
		fac[i]=fac[i]*2;
	int ans=1;
	for(i=1;i<=num;i++)
		ans=ans*(fac[i]+1);
	ans=(ans+1)/2;
	printf("Scenario #%d:\n",CASE);
	printf("%d\n",ans);
}

int main()
{
	int n,t,T;
	init();
	scanf("%d",&T);
	for(t=1;t<=T;t++)
	{
		scanf("%d",&n);
		solve(n,t);
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值